director3
?>

Написать программу, которая выводит целые числа в промежутку от 1 до 50, кратные двенадцати и считает их количество, сумму и произведение.

Информатика

Ответы

Юлия Соколовская1568

var amount, sum, multi, i: integer;

begin

   amount:= 0;

   sum:= 0;

   multi:= 1;

   for i:=1 to 51 do begin

       if i mod 12 = 0 then begin

           writeln(i);

           amount:= amount + 1;

           sum:= sum + i;

           multi:= multi * i;

       end;

   end;

   writeln(amount, ' ', sum, ' ', multi);

end.

amount = 0

sum = 0

multi = 1

for i in range(1, 51):

   if i % 12 == 0:

       print(i)

       amount += 1

       sum += i

       multi *= i

print(amount, ' ', sum, ' ', multi)

ilyagenius

Программное обеспе́чение (произношение обеспече́ние не рекомендуется) — наряду с аппаратными средствами, важнейшая составляющая информационных технологий, включающая компьютерные программы и данные, предназначенные для решения определённого круга задач и хранящиеся на машинных носителях.

Программное обеспечение представляет собой алгоритм, реализованный в виде последовательности инструкций для процессора.Системное ПО используется для обеспечения работы компьютера самого по себе и выполнения прикладных программ. Конкретные виды системного программного обеспечения включают загрузчики, операционные системы, драйверы устройств, утилиты (сервисные программы). Наиболее общая часть системного программного обеспечения – операционная системаОсновные функции ОС:

Загрузка приложений в оперативную память и их выполнение;

Стандартизованный доступ к периферийным устройствам (устройствам ввода-вывода);

Управление оперативной памятью;

Управление энергонезависимой памятью (жесткий диск, компакт-диски и т.д.), как правило, с файловой системы;

Пользовательский интерфейс.

platonm777639
A   B     C     NOT(B)   (A AND NOT B)   NOT(A AND NOT B)   OR C
0    0     0          1                  0                           1                     1
0    0     1          1                  0                           1                     1
0    1     0          0                  0                           1                     1
0    1     1          0                  0                           1                     1
1    0     0          1                  1                           0                     0
1    0     1          1                  1                           0                     1
1    1     0          0                  0                           1                     1
1    1     1          0                  0                           1                     1

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу, которая выводит целые числа в промежутку от 1 до 50, кратные двенадцати и считает их количество, сумму и произведение.
Ваше имя (никнейм)*
Email*
Комментарий*