С! нужно. составьте программу: дана таблица вещ таб b[1: 7]. замените каждый отрицательный элемент нулем. дана таблица вещ таб с[1: 10]. найдите максимальный элемент таблицы.
Flash-память представляет собой микросхему, помещенную в миниатюрный плоский корпус. Для считывания или записи информации карта памяти вставляется в специальные накопители, встроенные в мобильные устройства или подключаемые к компьютеру через USB-порт. Информационная емкость карт памяти может достигать 512 Мбайт.К недостаткам flash-памяти следует отнести то, что не существует единого стандарта и различные производители изготавливают несовместимые друг с другом по размерам и электрическим параметрам карты памяти.
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
С! нужно. составьте программу: дана таблица вещ таб b[1: 7]. замените каждый отрицательный элемент нулем. дана таблица вещ таб с[1: 10]. найдите максимальный элемент таблицы.
Первая часть
Program n_1;
var i:integer; B: array[1..7] of real;
begin
for i:=1 to 7 do begin
read(B[i]);
if B[i]<0 then B[i]:=0;
end;
for i:=1 to 7 do write(B[i]:0:5, ' ');
end.
Вторая часть
Program n_2;
var i:integer; a:real; C: array[1..10] of real;
begin
for i:=1 to 10 do begin
read(C[i]);
end;
a:=C[1];
for i:=1 to 10 do if (C[i]>a) then a:=C[i];
writeln(a:0:10);
end.