skyey
?>

Напишите программу, которая получает с клавиатуры трёхзначное число и записывает в логическую переменную значение «да» (true), если это все его цифры одинаковы. после этого на экран выводится ответ на вопрос: «верно ли, что все цифры введённого числа одинаковы? ». паскаль! ) с логической переменной

Информатика

Ответы

Анна1417

program znanija;

var

answer: boolean;

a,b,c,d: integer;

begin

readln(a);

b := a mod 10;

c := a div 100;

d := a div 10 mod 10;

if (b=c) and (c=d) then

answer := true;

if answer = true then

writeln ('Да, верно')

else

writeln ('Нет, не верно');

end.

zloshop9

var

   a : integer;

   d : boolean;

   

begin

   write('Введите трехзначное число -- ');

   readln(a);

   write('Верно ли, что все цифры введённого числа одинаковы? -- ');

   if a mod 10 and a div 10 mod 10 = a div 100 then d := true else d := false;

   if d then writeln('ДА') else writeln('НЕТ');

end.

Vladimir

Задача: Черепашке был дан для исполнения следующий алгоритм: Повтори 12 [Вперёд 50 Направо 60]. Какая фигура появится на экране?

Выполняя алгоритм, Черепашка оставляет след в виде одинаковых отрезков, расположенных под углом 180° − 60° = 120° друг к другу. Такой угол составляют между собой стороны правильного шестиугольника. Поэтому за первые шесть шагов алгоритма Черепашка нарисует правильный шестиугольник, а за следующие 5 шага пройдет по пяти его сторонам ещё раз. Следовательно, оставленный Черепашкой след представляет собой правильный шестиугольник.

departed744

Объяснение:

рлллолшчллы пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук тра3 я не знаю почему у тебя так же когда ты один ты постоянно пишешь звонишь хотя бы тоже поела и все больше ничего я не знаю почему у тебя р от меня надо было с 33333месяцев Тогда и 44беседовать

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, которая получает с клавиатуры трёхзначное число и записывает в логическую переменную значение «да» (true), если это все его цифры одинаковы. после этого на экран выводится ответ на вопрос: «верно ли, что все цифры введённого числа одинаковы? ». паскаль! ) с логической переменной
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

tolyan791
Sergei-Gradus199
osechkinandrejj
s-food
Стародубцева_Васильевич485
ver2bit
Иванов
skzzkt
Кирилл_Гульницкий
Svetlaru70
Boyaris
Владислав1246
boykoz9
Aleksandr
mnkrasnova