nsh25044
?>

Напишите программу, еоторая заполняет массив из 10 элементов случайными числами на отрезке [ -5; 5] и находит сумму ненулевых элементов. в системе паскаль. никак не могу составить, , .

Информатика

Ответы

Aleksandr_Vasilev
Конечно, я помогу тебе с заданием!

Вот пошаговое решение этой задачи на языке Паскаль:

1. Создадим переменную sum, которая будет хранить сумму ненулевых элементов массива.
```pascal
var
sum: integer;
```

2. Создадим массив из 10 элементов.
```pascal
var
arr: array[1..10] of integer;
```

3. Импортируем модуль для работы с генерацией случайных чисел.
```pascal
uses
Crt;
```

4. С помощью цикла for заполним массив случайными числами и найдем сумму ненулевых элементов.
```pascal
begin
randomize; // Инициализация генератора случайных чисел

sum := 0; // Инициализация суммы

for var i := 1 to 10 do // Цикл для заполнения массива и поиска суммы
begin
arr[i] := random(11) - 5; // Генерация случайного числа от -5 до 5
if arr[i] <> 0 then // Если элемент не равен нулю
sum := sum + arr[i]; // Увеличиваем сумму на значение элемента
end;
end.
```

5. Выведем на экран массив и сумму ненулевых элементов.
```pascal
writeln('Массив:');
for var i := 1 to 10 do
write(arr[i], ' ');
writeln;

writeln('Сумма ненулевых элементов:', sum);
```

Теперь у тебя есть полная программа на языке Паскаль, которая решает задачу. Программа генерирует массив из 10 элементов случайными числами в диапазоне [-5; 5] и находит сумму ненулевых элементов. После запуска программы на экран будет выведен массив и сумма ненулевых элементов.

Удачи с выполнением задания! Если есть дополнительные вопросы, не стесняйся задавать!

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, еоторая заполняет массив из 10 элементов случайными числами на отрезке [ -5; 5] и находит сумму ненулевых элементов. в системе паскаль. никак не могу составить, , .
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Федор_Рауф1592
Bogdanov
platonovkosty
bsi771184
Никита227
xobby18
fhf3624
Vladmouse32506
sokolowskayaa
olartamonov6
jurys71242
mb9037479491
vadimkayunusov
kseybar
seregina19706867