Тихонова
?>

***написать программу на языке паскальabc заданы массивы целых чисел x(n) и y(k все совершенные числа из этих массивов переписать в массив z. в массиве z найти четыре наименьших элемента массива. удалить из массива z все нулевые элементы результаты вывести на экран в восьмеричной системе заранее за !

Информатика

Ответы

NatalyaAlekseevich1644
Romanf romanf отличник 2013-01-10t16: 13: 22+00: 00 1. подумать над алгоритмом 2. вот сам алгоритм: а. спросить у пользователя значения б. расчитать ответ в. выдать ответ на экран 3. написать код в паскале 4. исправить ошибки компиляции 5. протестировать, вводить разные числа 6. обнаружила, что если вводить числа наугад ответ получается отрицательным иногда 7. вставить код проверки введенных пользователем значений 8. убрать ошибки компиляции 9. протестировать 10. готово а вот и сама программа: program aerobus; uses crt; const totalplace = 160; var businessplaces, economyplaces: integer; businessprice, economyprice: real; totalcharge: real; a,b: integer; correctinput: boolean; begin clrscr; businessplaces: =totalplace div 4; economyplaces: = totalplace - businessplaces; writeln('business places count: ', businessplaces); writeln('economy places count: ', economyplaces); correctinput: =false; while not correctinput do begin write('please input business class ticket price: '); readln(businessprice); if(businessprice> 0) then begin correctinput: =true; end else begin writeln('the price should be a positive number, please try again'); end; end; economyprice: =businessprice/2; writeln('economy ticket price is: ', economyprice: 0: 2); correctinput: =false; while not correctinput do begin write('how many business tickets are left? : '); readln(a); if(a> =0) and (a< =businessplaces)then correctinput: =true; if(a< 0) then begin writeln('please input a positive number or 0, please try again'); end; if(a> businessplaces) then begin writeln('please input a number which is less or equal to the tolal business place count, please try again'); end; end; correctinput: =false; while not correctinput do begin write('how many economy tickets are left? : '); readln(b); if(b> =0) and (b< =economyplaces)then correctinput: =true; if(b< 0) then begin writeln('please input a positive number or 0, please try again'); end; if(b> economyplaces) then begin writeln('please input a number which is less or equal to the tolal economy place count, please try again'); end; end; totalcharge: =(businessplaces-a)*businessprice; totalcharge: =totalcharge+(economyplaces-b)*economyprice; writeln('the total charge is: ', totalcharge: 0: 2); writeln; writeln('press enter to exit'); readln; end.
jeep75
Var     n, m, sum: integer;   begin     sum : = 0;     repeat     writeln('введите числ с которого начинается ряд');     readln(n);     writeln('введите число которым заканчивается ряд');     readln(m);     until n< m;       if odd(n) then n : = n + 1;     if odd(m) then m : = m - 1;     sum : = (n + m) * (m - n + 2) div 4;     writeln('сумма чётных чисел натурального ряда: ', sum); end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

***написать программу на языке паскальabc заданы массивы целых чисел x(n) и y(k все совершенные числа из этих массивов переписать в массив z. в массиве z найти четыре наименьших элемента массива. удалить из массива z все нулевые элементы результаты вывести на экран в восьмеричной системе заранее за !
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

AndreevManaeva
lavorenn
Ivanovich_Kostik898
nord248
studiojanara
Лилия-Карпухина337
Nikolaevich-Svetlana388
guujuu
optikmir
Елена Васильева839
madina27821667
modos201276
Boss5519
zubareva23338
rytikovabs
▲