AndreiFaikov1943
?>

Написать программу на паскале: в школе альтаир занятия проводятся каждый день по 3 или 5 уроков. миша приехал на n уроков. необходимо определить сколько у него будет дней по 5 уроков, а сколько по 3, при этом суммарное количество дней должно быть минимальным.

Информатика

Ответы

Bologova Golovach1989
Const 
n=5;

Var
 ar:array[1..n] of integer;
 ar2:array[1..n] of integer;
 i,k:integer;

 function prost(a:integer):boolean;
 var i:integer;
 b:boolean;
  begin
  b:=true;
   for i:=2 to a div 2 do
    if a mod i=0 then
     begin;
      b:=false;
      break;
     end;
   if a=1 then b:=false;
  prost:=b;
 end;

  begin;
 randomize;
 k:=0;
  for i:=1 to n do
   begin;
    ar[i]:=random(101);
    write(ar[i]:4);
   end;
  writeln;
  for i:=1 to n do
  if prost(ar[i]) then
   begin;
    inc(k);
    ar2[k]:=ar[i];
    write(ar2[k]:4);
   end;
end.
mmurzina
Поиск простых делителей числа:

var i,j,n:longint;
    f:boolean;
begin
 writeln('Введите число');
 readln(n);
  if n<2 then writeln('Простых делителей нет')
  else
   begin
    write('Число ',n,' ','= 1');
    for i:=2 to n do
     if n mod i=0 then
      begin
       f:=true;
       j:=2;
       while f and(j<=round(sqrt(i/2)))do
        begin
         if i mod j=0 then f:=false
         else j:=j+1;
        end;
      if f then write('*',i);
     end;
   end;
end.

Тестовое решение:

Введите число
2345
Число 2345 = 1*5*7*35*67

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу на паскале: в школе альтаир занятия проводятся каждый день по 3 или 5 уроков. миша приехал на n уроков. необходимо определить сколько у него будет дней по 5 уроков, а сколько по 3, при этом суммарное количество дней должно быть минимальным.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

DzukaevAlekseevich
emilmishin1032
mariyachervonnaya44
Sergei-Gradus199
narkimry134
Попов1946
expo3217
Андреевич
saytru5850
household193
saint158
zalev
Kashirina
margo55577869
Stroeva19651938