starh
?>

нужна ! ! составить программу вывода на печать наибольшего из трех неравных между собой чисел надо написать это на с++

Информатика

Ответы

Михайлович_гергиевич315

#include<iostream>

int main()

{

double a,b,c;

std::cout << "Enter a,b,c:";

std::cin >> a >> b >> c;

if (a>b && a>c) std::cout << a;

if (b>a && b>c) std::cout << b;

if (c>a && c>b) std::cout << c;

return 0;

}

Объяснение:


нужна ! ! составить программу вывода на печать наибольшего из трех неравных между собой чисел над
kyrtlab39
515b - в шестнадцетиричной СС(Системе Счисления)
b - под номер 11 так как 0,1..9 10(a) 11(b) 12(c)
Шестнадцатиричная СС состоит из 0,1..9 10(a) 11(b) 12(c) .. 15(f)

ответ: 515b - шестнадцетиричная (16)
           4305 - десятичная (10) или шестиричная (6)
           9463 - десятичная (10) или десятичная (10), если отталкивать от условия "основание системы счисления должно быть больше 2 и не больше 36" а правильно я отметил я изучал 3 СС: (двоичная СС, десятичная, шестнадцетиричная, есть и другие не отрицаю)
Eduardovich

// PascalABC.NET 3.6.3

uses School;

function Divizors(n: integer): List<integer>;

begin

 var L := new List<integer>;

 L.Add(1);

 L.Add(n);

 if n > 3 then

   begin

   var k := 2;

   while (k * k <= n) and (k < 46341) do

   begin

     if n mod k = 0 then

     begin

       var t := n div k;

       L.Add(k);

       if k < t then L.Add(t)

       else break

     end;  

     Inc(k)

   end;

   L.Sort;

 end;

 Result := L

end;

begin

 // 1

 if ReadInteger.IsPrime then Println('YES')

 else Println('NO');

 // 2

 ReadInteger.Factorize.First.Println;

 // 3

 var a := Divizors(ReadInteger);

 Print(a.Count, a.Sum)

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

нужна ! ! составить программу вывода на печать наибольшего из трех неравных между собой чисел надо написать это на с++
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Bmashutav16
Виктор Попова
Albina
Anatolevich_Kulikov1229
samofar
Татьяна Марина1287
deshkina82
Yekaterina Oksyuta1657
abrolchik8511
taanaami75
mahalama7359
ielienakozlova696
prianik6
dimiff5
sinicin80