Калмыкова-Петрунина
?>

9класс фастом написать программу, заполняющую массив 30 случайными числами [-10..80]. вывести массив. определить в этом массиве сумму чисел, кратных 3 определить количество отрицательных чисел. определить в этом массиве номер элемента, равного 0

Информатика

Ответы

tribunskavictory

Var a: array [1..30] of integer;

sum3,otr,i,j:integer;

begin

randomize;

sum3:=0;

otr:=0;

for i:=1 to 30 do  

 begin

   a[i]:=random(91)-10;

   write(a[i]:4);

   if a[i] mod 3 = 0 then sum3:=sum3+a[i];

   if a[i]<0 then inc(otr);

 end;

 writeln;

 writeln('Sum: ',sum3,'   <0:',otr);

 for i:=1 to 30 do

   if a[i]=0 then  

     begin

      writeln('№',i,'=0');

     end;

end.

bondarev05071962

Единицы измерения информации

В 1 бит можно записать один двоичный символ.

1 байт = 8 бит

В кодировке ASCII в один байт можно записать один 256 символьный код

В кодировке UNICODE один 256 символьный код занимает в памяти два байта

1 килобайт = 1024 байт

1 мегабайт = 1024 килобайт

1 гигабайт = 1024 мегабайт

1 терабайт = 1024 гигабайт

Формула Хартли 2 i = N где i- количество информации в битах, N - неопределенность

Таблица степеней двойки, которая показывает сколько информации можно закодировать с бит

i

0

1

2

3

4

5

6

7

8

9

10

N=2 i

1

2

4

8

16

32

64

128

256

512

1024

Чтобы вычислить информационный объем сообщения надо количество символов умножить на число бит, которое требуется для хранения одного символа

ann-perminova2008

Для того, чтобы определить какое значение будет принимать переменная Х, после выполнения фрагмента исходной программы, пройдем по этой программе вручную следующим образом:

1) а: =4, b: = 5, с: = 3.

2) If a > b then x: = a + b

4 > 5 - не верно, значит переходим на следующий шаг программы после ключевого слова else:

3) else begin

a: = b + c = 5 + 3 = 8; получили, что значение a теперь равняется 8.

x:= а - 3 * b = 8 - 3 * 5 = 8 - 15 = -7.

4) Поскольку следующим идет команда end, значит программа завершает и получаем значение x: = -7.

Таким образом правильный вариант ответа - г).

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

9класс фастом написать программу, заполняющую массив 30 случайными числами [-10..80]. вывести массив. определить в этом массиве сумму чисел, кратных 3 определить количество отрицательных чисел. определить в этом массиве номер элемента, равного 0
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

makitra08
Sazhina1356
yna21289
valera850515
info2471
expo3217
moisalexx7
aidapiltoyan43
mkrtchyananaida6995
ВладимировнаИП37
brakebox
preida-2
zhunina71807
Валерия Воробьева396
Станислав Валерий1696