tvmigunova551
?>

Написать программу (паскаль) в массиве хранится информация о стоимости 1 кг 20 видов конфет. определить, сколько стоят самые дешёвые конфеты . если таких несколько, то должен быть найден индекс первого из них .

Информатика

Ответы

buhtovarish

program test;

var a:array [1..20] of integer;

min, i, imin: integer;

begin

min:=a[19];

imin:=19;

for i:=1 to 20 do begin

a[i]:=random (151)+150;

write (a[i]:4);

end;

writeln;

for i:=19 downto 1 do begin

if a[i]<min then begin imin:=i; min:=a[i]; end;

end;

write (imin);

writeln;

write (a[imin]);

end.

Кристина_Memmedov
#include <iostream>
using namespace std;
int main()
{ setlocale(0,"");
int a;
cout<<"введите значение погоды"<<endl;
cout<<"1-тепло"<<endl;
cout<<"2-жарко"<<endl;
cout<<"3-холодно"<<endl;
cout<<"4-колотун"<<endl;
cin>>a;
switch (a)
{
case 1: cout<<"вы можете одеть джинсы и футболку"<<endl; break;
case 2: cout<<"вы можете одеть шорты и майку "<<endl; break;
case 3: cout<<"вы можете одеть штаны и толстовку "<<endl; break;
case 4: cout<<"вы можете одеть куртку и свитер с подштанниками и ватными штанми "<<endl;
 break;
}
return 0;
}
olegtarasov1965

Условный оператор позволяет проверить некоторое условие и в зависимости от результатов проверки выполнить то или иное действие. Таким образом, условный оператор - это средство ветвления вычислительного процесса.

Структура условного оператора имеет следующий вид:

if <условие> then <оператор1> else <оператор2>;

где if/ then/ else - зарезервированные слова (если, то, иначе);

<условие> - произвольное выражение логического типа;

<оператор1>, <оператор2> - любые операторы языка Object Pascal.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу (паскаль) в массиве хранится информация о стоимости 1 кг 20 видов конфет. определить, сколько стоят самые дешёвые конфеты . если таких несколько, то должен быть найден индекс первого из них .
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Александровна1685
nadjasokolova2017
mmihail146
mac4roc3781
basil69
Илья_Ветклиники1655
NikolayGoncharov
oafanasiev41
Tochkamail370
igorshevkun
margo929
Марина Федорович924
Nikishina
mail9
optikmir