Объяснение:
Схе́ма Го́рнера (или правило Горнера, метод Горнера, метод Руффини-Горнера) — алгоритм вычисления значения многочлена, записанного в виде суммы мономов (одночленов), при заданном значении переменной. Метод Горнера позволяет найти корни многочлена[1], а также вычислить производные полинома в заданной точке. Схема Горнера также является простым алгоритмом для деления многочлена на бином вида {\displaystyle x-c}x-c. Метод назван в честь Уильяма Джорджа Горнера, однако Паоло Руффини опередил Горнера на 15 лет, а китайцам этот был известен еще в XIII веке.
Поделитесь своими знаниями, ответьте на вопрос:
Pascal: написать программу расчета количества рулонов обоев шириной d см, если известны длина, ширина, высота комнаты (a, b, c), размеры одного окна (m, n) и одной двери (p, k дверь одна, окно тоже.
var
a, b, c, d, l, m, n, p, k, r: integer;
S, u: real;
begin
writeln('Оклейка комнаты обоями. Все размеры в см.');
write('Укажи длину, ширину и высоту комнаты: ');
readln(a, b, c);
write('Укажи ширину и высоту двери: ');
readln(p, k);
write('Укажи ширину и высоту окна: ');
readln(m, n);
write('Укажи длину и ширину рулона обоев: ');
readln(l, d);
S := 2 * c * (a + b) - p * k - m * n; { площадь оклейки }
u := l * d; { площадь одного рулона }
r := Trunc(S / u);
if Frac(S / u) > 0.05 then
r := r + 1;
writeln('Потребуется рулонов: ', r)
end.