fullhouse9991
?>

Создать стек из случайных целых чисел и найти в нем максимальное и минимальное значение. (решить в паскале)

Информатика

Ответы

ПаршинАндрей1928

===== PascalABC.NET =====

begin

 var n := ReadInteger('Сколько чисел сгенерировать?');

 var St := new Stack<integer>(SeqRandom(n, -99, 99));

 St.Println;

 Println('Max =', St.Max, '   min =', St.Min);

 // следующие строки не нужны, это просто проверка,

 // что стек после обработки не сломался.

 Writeln;

 St.Pop.Println;

 St.Println;

end.


Создать стек из случайных целых чисел и найти в нем максимальное и минимальное значение. (решить в п
Людмила902
Если построить простейшую модель окружающей человека действительности, то Мир – бесконечное множество объектов реальности. Человек-Наблюдатель – достаточно сложная, также бесконечная информационно объединенная в единое целое структура, в силу своих возможностей адекватно отображающая внешний Мир. Главное в этой модели то, что мощность множества объектов внешнего мира больше, в математическом смысле, мощности множества объектов, которые могут быть отображены в сознании Человека. Элементарное следствие этой модели – все люди равны перед проклятьем бесконечности, и академик и простолюдин. Все важны для эволюции. Поэтому развитие робототехники не является угрозой для существования человека. В бесконечном разнообразии всем найдется место. В лоб бороться с проклятьем бесконечности можно только увеличив количество интеллектуалов, занятых поиском общей для всех истины. При этом, чем больше людей, тем лучше. Поэтому, не исключено, что через 50 или 100 лет население возрастет в тысячи или даже миллионы раз. Мы находимся в начале экспансии человечества в бесконечный космос. И без автоматических устройств построить ниши для жилья в космосе невозможно. Большинство из окружающих нас не заметили, что в 1997 году мы незаметно перешагнули барьер, отделяющий  общество товарно-денежных отношений от информационного общества. В мае 1997 г, когда компьютер победил в шахматной игре человека, чемпиона мира Г.Каспарова  стало ясно что будущее не принадлежит роботам, как и не принадлежит человеку. Будущее за своеобразным кентавром, человеко-машинным комплексом – симбиозом искусственного интеллекта, который решает штатные стандартные задачи, и человеком, который ставит эти задачи и отвечает за все. Уже сейчас прогресс во множестве областей предметной деятельности человека определяется этим «кентавром». 
Егорова
Var a:char;
begin
writeln('Введите букву');
readln(a);
case a of
'q': writeln('w');
'w': writeln('e');
'e': writeln('r');
'r': writeln('t');
't': writeln('y');
'y': writeln('u');
'u': writeln('i');
'i': writeln('o');
'o': writeln('p');
'p': writeln('a');
'a': writeln('s');
's': writeln('d');
'd': writeln('f');
'f': writeln('g');
'g': writeln('h');
'h': writeln('j');
'j': writeln('k');
'k': writeln('l');
'l': writeln('z');
'z': writeln('x');
'x': writeln('c');
'c': writeln('v');
'v': writeln('b');
'b': writeln('n');
'n': writeln('m');
'm': writeln('q');
end;
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Создать стек из случайных целых чисел и найти в нем максимальное и минимальное значение. (решить в паскале)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Orestov563
Андреевич-Екатерина1974
Aleksandr
yastrik
Savelieva24
mnkrasnova
shoko-2379
alexkortyukov
tokarevaiv
Васильев1028
elmira01048775
ASRodichev
AkulovaAnastasiya
Людмила