Потапова 79275136869323
?>

Нужно написать программу на языке с++ которая должна: проверить трехзначное число на четность и найти сумму его цифр, если число четное, или произведение его цифр, если число нечетное.

Информатика

Ответы

egoryuzbashev

#include <iostream>

using namespace std;

int main()

{

   int n;

   cin >> n;

   n = abs(n); // если введут отрицательное

   if(n > 99 && n < 1000)

   {

       int d1, d10, d100;

       d1 = n % 10;

       d100 = n / 100;

       d10 = n / 10 % 10;

       int r;

       if(n % 2 == 0)

           r = d100 + d10 + d1;

       else

           r = d100 * d10 * d1;

       cout << r;

   }

   else

       cout << "Число не трехзначное";

   return 0;

}

galinab1111326

Объяснение:

При работе на персональном компьютере довольно часто возникает необходимость уменьшить размер файла с целью экономии места на диске. Например, требуется перенести файлы с одного компьютера на другой на дискетах. Или нужно переслать большой файл по электронной почте - уменьшив его размер, можно сэкономить и время и деньги. Лучшее решение в таких случаях - создать так называемый архивный файл, или, проще говоря, архив. Это единый файл, в который для компактного хранения информации помещены в сжатом виде один или несколько исходных файлов.

Для работы с архивами предназначены специальные программы, которые называются архиваторами. С архиваторов можно упаковывать файлы в архивы и распаковывать их, а также просматривать содержимое архивов. Упаковка файлов в архив называется архивированием или архивацией, а их извлечение - разархивированием.

Существуют разные форматы архивов: ZIP, ARJ, RAR, CAB, TAR, LZH и др. Когда создается архивный файл, ему присваивается расширение, совпадающее с форматом архива. Например, файл с именем MyDoc.zip - это архив формата ZIP. Формат влияет на эффективность сжатия файлов; к примеру, архив формата RAR занимает на диске меньше места, чем архив формата ZIP, содержащий те же самые исходные файлы. Кроме того, эффективность зависит от типа файлов, упаковываемых в архив. Файлы картинок, имеющие расширение BMP, документы Microsoft Word удается сжать в два-четыре раза, текстовые файлы - приблизительно в два раза. Несколько хуже подвержены сжатию исполняемые файлы (с расширением EXE), а графические файлы, имеющие расширение TIF, практически не сжимаются.

oloinics
Эту задачу очень легко решить при логарифмов. Если при делении логарифма числа на логарифм пяти получится целое число, то искомое есть степень пятерки, а результат деления и есть показатель степени.

На примере: lg(125) / lg(5) = 3.  Так как 5³ = 125
lg(812) / lg(5) ≈ 4.16 поэтому 812 не явл. степенью 5-ки.

print "Введите число"
input A
S = log(A) / log(5)
if S = int(S) then
   print "Число ";А; "является степенью числа 5"
   print "Показатель степени "; S
else
   print "Число ";А; "не является степенью числа 5"
end if
end

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Нужно написать программу на языке с++ которая должна: проверить трехзначное число на четность и найти сумму его цифр, если число четное, или произведение его цифр, если число нечетное.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Nikolaevna1623
andreanikin
Demina-Khokhlov584
Vika-simonenko
Владимирович_Слабый
Код для создания веб-сайта в блокноте
marinavg63607
peresvetoff100015
charlie79
Zebra198383
olofinskayae
eoils-info
dima0218687
Nikita
purchase
Tyukalova
▲