Mariya987
?>

Вычеркивание. пользователь вводит целое трехзначное число. программа сообщает какую цифру в нём вычеркнуть чтобы оставшееся двузначное число было максимально возможным. например, в числе 513 выгоднее вычеркнуть вторую цифру.нужно составить программу в pascal.​

Информатика

Ответы

Эрендженова

Объяснение:

var a,b:real; c,e:integer;

begin

writeln('Введите два целых числа');

readln(a);

// нет ввода второго целого числа. надо написать readln(b);

c:=a/b; //ошибка! при делении может получится дробное число, а с указано как целое

d:=a mod b; //переменная d не описана в разделе var

e:=c+d;

writeln(c);

writeln(d);

writeln(e);

end.

Готовая программа:

var c, e:real; a,b,d:integer;

begin

writeln('Введите два целых числа');

readln(a);

readln(b);

c:=a/b;

d:=a mod b;

e:=c+d;

writeln(c);

writeln(d);

writeln(e);

end.

znaberd786

from random import randint

class G:

def __init__(self):

 self.wins = 0

def menu(self):

 print("stop - для остановки решения\nEnter продолжение.")

 while 1:

  if self.wins > 5:

   print("Ты хорошо справился, думаю на сегодня хватит")

   G.result(self)

   break

  a = input(": ")

  if a == "stop":

   G.result(self)

   break

  elif a == "":

   G.game(self)

  else: pass

def game(self):

 n1,n2 = randint(1,100),randint(1,100)  # примеры от и до

 print(f"Сколько будет: {n1} + {n2}?")

 if int(input("ответ: ")) == n1+n2:

  print("Верно")

  self.wins += 1

 else:

  print("Неверно")

 if self.wins != 5+1:

  print("Продолжим? Нажите Enter ля решения другого примера, введите stop для окончания")

def result(self):

 print("игра остановлена")

 print(f"Количество верных ответов: {self.wins}")

 if self.wins > 5:

  print("Молодец!")

 else:

  print("Потренируйся ещё")

a = G()

a.menu()


Напишите программу на python которая генерирует случайный пример на сложение двух чисел, например

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Вычеркивание. пользователь вводит целое трехзначное число. программа сообщает какую цифру в нём вычеркнуть чтобы оставшееся двузначное число было максимально возможным. например, в числе 513 выгоднее вычеркнуть вторую цифру.нужно составить программу в pascal.​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

andrewa
sigidinv
chetverikovalex3738
vitaliy
mrilyushchenko6
marinaled8187
s9152992722344
agitahell149
ivan-chay19
sryzhova6392
optima3559
anastasiavilina
alex07071
kuchin
alislisa191