program a;
type
Ta = array of Integer;
procedure Sort (var a: Ta);
var
i, j, jmax, atmp: Integer;
begin
for i := Low (a) to High (a) do begin
jmax := i;
for j := i + 1 to High (a) do begin
if a [j] < a [jmax] then // возрастание и убывание меняется знаком "<" или ">" в этом операторе
jmax := j;
end;
atmp := a [i];
a [i] := a [jmax];
a [jmax] := atmp;
end;
end;
var
n, i: Integer;
a: Ta;
begin
Write ('Количество элементов: ');
ReadLn (n);
SetLength (a, n);
for i := Low (a) to High (a) do
Read (a [i]);
Sort (a);
for i := Low (a) to High (a) do
Write (a [i], ' ');
ReadLn;
ReadLn;
end.
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
program b;
type
Ta = array of Integer;
procedure Sort (var a: Ta);
var
i, j, jmax, atmp: Integer;
begin
for i := Low (a) to High (a) do begin
jmax := i;
for j := i + 1 to High (a) do begin
if a [j] < a [jmax] then // возрастание и убывание меняется знаком "<" или ">" в этом операторе
jmax := j;
end;
atmp := a [i];
a [i] := a [jmax];
a [jmax] := atmp;
end;
end;
procedure InArr (var a: Ta);
var
i, n: Integer;
begin
Write ('Количество элементов: ');
ReadLn (n);
SetLength (a, n);
for i := Low (a) to High (a) do
Read (a [i]);
end;
var
n, i, l1, l2: Integer;
a1, a2: Ta;
begin
Write ('Первый массив.');
InArr (a1);
Write ('Второй массив.');
InArr (a2);
l1 := Length (a1);
l2 := Length (a2);
SetLength (a1, l1 + l2);
for i := Low (a2) to High (a2) do
a1 [i + l1] := a2 [i];
Sort (a1);
for i := Low (a1) to High (a1) do
Write (a1 [i], ' ');
ReadLn;
ReadLn;
end.
Поделитесь своими знаниями, ответьте на вопрос:
Напишите программу, которая вводит четырехзначное число и "вырезает" из него вторую цифру с начала, например, из числа 1234 должно получиться число 134 написать на языке
ответ: добавил <limits.h>, хотя на Visual С++ у меня без этого работало, и условие && a != 0 (что то не везёт мне с этой задачей)
#include <iostream>
#include <limits.h>
using namespace std;
int main()
{
int a, i, imin, amin;
setlocale(LC_ALL, "Russian");
cout << "Введите числа: ";
i = 0;
amin = INT_MAX;
imin = 0;
do {
i++;
cin >> a;
if (a < amin && a != 0) {
amin = a;
imin = i;
}
} while (a != 0);
if (i > 1)
cout << "\n№ минимального элемента = " << imin << endl;
else
cout << "\nПоследовательность пустая" << endl;
getchar();
}