Bulanova
?>

1. определить, можно ли описать круг с радиусом r около квадрата со стороной а (описанная окружность проходит через все вершины квадрата)2. напишите программу, которая переводит оценку в пропись ( «1» - плохо, «2» - неудовлетворительно, «3» - удовлетворительно, «4» - хорошо, «5» - отлично, оценка вводится пользователем, только одна)3. определите количество отрицательных чисел в диапазоне (границы указывает пользователь)программа паскаль, заранее

Информатика

Ответы

AHO436
Алгоритм
1) a x a = a² ⇒ b;    b x a = a³ ⇒ результат
2) a x a = a² ⇒ b;    b x b = a⁴ ⇒ c;   c x c = a⁸ ⇒ c;   c x b = a¹⁰ ⇒ результат

Программа на языке PascalABC.Net
var
  a,b,c,y:real;
begin
  Write('Введите число: '); Read(a);
  b:=a*a; y:=b*a; Writeln('Третья степень числа равна ',y);
  c:=b*b; c:=c*c; y:=b*c;
  Writeln('Десятая степень числа равна ',y)
end.

Тестовые решения:
Введите число: 2
Третья степень числа равна 8
Десятая степень числа равна 1024

Введите число: -13.594
Третья степень числа равна -2512.128188584
Десятая степень числа равна 215512594781.574
koxhulya61
1) Как представлено число 8310 в двоичной системе счисления?
В этом вопросе нет ни одного числа двоичного кода. В двоичном коде будет: 10000001110110
2) Дано: , . Какое из чисел С, записанных в двоичной системе счисления, удовлетворяет неравенству ? Я думаю, что вопрос звучал так: Дано: a=222 8 , b=94 Какое из чисел С, записанных в двоичной системе счисления, удовлетворяет неравенству?ответ:2)  С = 250(8сч) удоволетворяет неравенству а=247 меньше С=250 и b= 251 больше С=250.
3) Даны 4 целых числа, записанные в двоичной системе...
ответ: все четыре числа меньше чем 396
4) Укажите через запятую в порядке возрастания все основания систем счисления, в которых запись числа 39 оканчивается на 3.
ответ: 4, 6, 9, 12, 18, 36
5) Запись числа 30 в некоторой системе счисления выглядит так: 110N. Найдите основание системы счисления N.
1)30=1*N^{2}+*N^{1}+*N^{0}
N^{2}+N-30=0
(N+6)(N-5)=0 N\geq=5
2)2B_{16}=2*16+11=43=1*N^{1}+1*N^{0}
N^{2}+N-42=0
(N+7)(N-6)=^{0}N \geq 0 N=6
6) Решить уравнение: где????????????????
7) Сколько единиц в двоичной записи числа 42016 + 22018 – 6?
Я не смог решить
8) Значение арифметического выражения: 274 – 95 + 38 – 25 записали в системе счисления с основанием 3. Сколько цифр «2» содержится в этой записи?
Я не смог решить

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1. определить, можно ли описать круг с радиусом r около квадрата со стороной а (описанная окружность проходит через все вершины квадрата)2. напишите программу, которая переводит оценку в пропись ( «1» - плохо, «2» - неудовлетворительно, «3» - удовлетворительно, «4» - хорошо, «5» - отлично, оценка вводится пользователем, только одна)3. определите количество отрицательных чисел в диапазоне (границы указывает пользователь)программа паскаль, заранее
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Galina-Marat1096
Елена-Олег
Нана_Елена
DodokhodzhaevVladimirovich
gusrva3001
NIKOLAI
yocrew13
Татьяна1045
ГусенковФролова1121
tarasovs
Coffee3862
agrilandrussia
Test Станислав
nasrelza1012
Ольга Сергей1822