werda84
?>

Вариант 1. 1. определите значение переменной «а» после выполнения фрагмента программы: а: = 10; ifa> 4 then а: = 6+а; 2. определите значение переменной «а» после выполнения фрагмента программы: а: = 10; if a < 15 then а: =a+ 12 else а: =a-7; 3. определите значение переменной «а» после выполнения фрагмента программы: а: = 10; if a > 5 then a : = a + 12 else a: = a - 7; if a > 5 then a : = a + 12 else a: = a - 7;

Информатика

Ответы

sargisyan77
Const
n=10;m=7;
var
a:array[1..n,1..m]of integer;
i,j,min,s,j_m:integer;
     begin     
         for i:=1 to n do         
               begin             
                  writeln;                     
                     for j:=1 to m do                         
                          begin                               
                              a[i,j]:=random(20)-5;                             
                              write(a[i,j]:4);                         
                          end;       
                end;         
writeln;  
{запишем в min чуть больше наибольшего значения суммы, которая может быть в любом столбце. Больше, чем 200 не будет, т.к. всего 10 строк, каждое значение исходя из заполнения матрицы не может быть больше, чем 15 }
min:=200;j_m:=1;
            for j:=1 to m do         
                begin             
                    s:=0;                   
                       for i:=1 to n do                     
                            s:=s+a[i,j];                   
                               if s<min then                     
                                    begin                           
                                       j_m:=j;                         
                                       min:=s;                     
                                    end;             
                              writeln('j :',j,' ',s);  {выводится значение суммы в каждом столбце, необязательно, можно удалить}       
                 end;         
writeln('№ столбца с мин суммой ',j_m);     
     for i:=1 to n do         
            writeln(a[i,j_m]); {вывод нужного столбца}
end.                           
Демидова Красноцветов
1.                                                        

program raf105;

var a,sum:integer;

begin

writeln('Вводите числа по очереди');

writeln('Чтобы закончить введите 0');

repeat

 readln(a);

 sum+= a;

until a=0;

writeln('Сумма: ',sum);

end.

2.                                                        

program raf105;

var

s:string;

i,k,j:integer;

poli:boolean;

begin

poli:= true;

write('Введите слово: ');

readln(s);

s:= lowercase(s);

k:= length(s) div 2;

j:= k*2+1;

if (length(s) mod 2)<>0

 then j+= 1;

for i:=1 to k do

begin

 j-=1;

 if poli

   then poli:= s[i] = s[j];

end;

if poli

 then writeln('Слово - палиндром')

 else writeln('Слово - не палиндром');

end.

 

3.                                                        

program raf105;

var a:array[1..10] of integer;

x,i:integer;

begin

writeln('Вводите 10 чисел по очереди');

for i:=1 to 10 do

 readln(a[i]);

write('Введите искомое число: ');

readln(x);

write('Индексы совпадающих элементов: ');

for i:=1 to 10 do

 if a[i] = x

   then write(i,' ');

end.

4.                                                        

program raf105;

var a:integer;

begin

write('Введите номер дня недели: ');

readln(a);

case a of

 1: writeln('Это Понедельник');

 2: writeln('Это Вторник');

 3: writeln('Это Среда');

 4: writeln('Это Четверг');

 5: writeln('Это Пятница');

 6: writeln('Это Суббота');

 7: writeln('Это Воскресенье');

end;

end.

5.                                                        

program raf105;

var a:array[1..100] of integer;

i,o,x: integer;

begin

writeln('Вводите числа по очереди');

writeln('Чтобы закончить введите 0');

repeat

 o+= 1;

 readln(a[o]);

until a[o]=0;

o-= 1;

writeln('Введённые числа в обратном порядке:');

for i:=o downto 1 do

 writeln(a[i]);

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Вариант 1. 1. определите значение переменной «а» после выполнения фрагмента программы: а: = 10; ifa> 4 then а: = 6+а; 2. определите значение переменной «а» после выполнения фрагмента программы: а: = 10; if a < 15 then а: =a+ 12 else а: =a-7; 3. определите значение переменной «а» после выполнения фрагмента программы: а: = 10; if a > 5 then a : = a + 12 else a: = a - 7; if a > 5 then a : = a + 12 else a: = a - 7;
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

most315
Khrimyan1207
Fedorovna
Suralevartem
s777tver109
vanvangog199826
kirill76536
oksana77768
Kelena190533
КузменковаЖигулин
vfif-804828
Vladimirovich1898
Катерина Телюкин925
stsnab
Yuliya-Tsaryova