uchpaot
?>

Написать программу по информатике (можно на pascal или на c++)! количество минимумовнайдите количество минимальных элементов в последовательности.входные данныевводится натуральное число n, а затем n чисел.выходные данныевыведите количество минимальных элементов.например : мы вводим : 3 21114на выходе получаем : 1​

Информатика

Ответы

Chutaeva381

#include <iostream>

using namespace std;

void main(){

int N, a, min, cmin;

cin >> N;

cin >> min;

cmin = 1;

for(int i=1; i<N;i++){

cin >> a;

if(min==a)

cmin++;

if(min>a){

min = a;

cmin = 1;

}

}

cout << cmin;

}

ccc712835

PascalABC.NET (Обязательно .NET, используется библиотека классов .NET)

begin

 var list: List<integer> := new List<integer>;

 var N := ReadInteger();

 for var i := 1 to N do

 begin

   list.Add(ReadInteger());

 end;

 

 list.Where(x -> x = list.Min()).Count.Println();

end.

Объяснение:

mel9152480522
Program zzz;
var A,B,C: array[1..20] of integer; SB,SC: integer; i,kb,kc: byte;
begin
  kb:=0; //количесво элементов в массиве B
  kc:=0; //количесво элементов в массиве C
  SB:=0; //сумма элементов массива B
  SC:=0; //сумма элементов массива C
  For i:=1 to 20 do begin
    writeln('введите ',i,'-й элемент массива');
    readln (A[i]);
    if A[i]>=0
      then begin kb:=kb+1; B[kb]:=A[i]; SB:=SB+B[kb] end
      else begin kc:=kc+1; C[kc]:=A[i]; SC:=SC+C[kc] end
  end;
  writeln(kb:4, sb:8, kc:4, sc:8);
end.
apromovich1
#include <string.h>
#include <iostream>

int main() {
  int maxslov = 10;
  char *slovar[maxslov];
  slovar[0] = "Информатика";
  slovar[1] = "Математика";
  slovar[2] = "Алгебра";
  slovar[3] = "Имя";
  slovar[4] = "Паскаль";
  slovar[5] = "Папка";
  slovar[6] = "Сайт";
  slovar[7] = "Вегас";
  slovar[8] = "Телефон";
  slovar[9] = "Пара";
  char *pr[8] = {" ", ".", ",", ";", ":", "-", "!", "?"};
  char *s, *sl;
  int i, j, k;
  bool punct;

  while (true) {
    std::cout<<"s=";
    std::cin>>s;
    s = strcat(s, " ");
    sl = "";
    for ( i = 0; i <= strlen(s); i++ ) {
      for ( j = 0; j <= 8; j++ ) {
        if ( strcmp(pr[j], s[i]) ) {
          punct = true;
        }
        else {
          punct = false;
        }
      }
      if ( !(punct) ) {
        sl = strcat(sl, s[i]);
      }
      else {
        if ( strlen(sl) > 0 ) {
          k = 0;
          for ( j = 0; j <= maxslov; j++ ) {
            if (slovar[j] = sl) {
              k++;
            }
          }
          if (k = 0) {
            std::cout<<"Слово \""<<sl<<"\" написано неправильно,или не найдено в словаре."<<endl;
          }
          else {
            std::cout<<"Слово \""<<sl<<"\" написано правильно."<<std::endl;
          }
          sl = " ";
        }
      }
    }
  }
  return 0;
}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу по информатике (можно на pascal или на c++)! количество минимумовнайдите количество минимальных элементов в последовательности.входные данныевводится натуральное число n, а затем n чисел.выходные данныевыведите количество минимальных элементов.например : мы вводим : 3 21114на выходе получаем : 1​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

cashuta
kmalahov
Алина Ракитин1730
YekaterinaAbinskov
vallium8354
webotryvclub21
infosmolenskay
lirene
MN-Natusik80
Powerbasses5521
Yelizaveta1848
kyrtlab39
mishagoride885
Anna_Kamil
yfetyukov
▲