Дружинин
?>

Составить программу на pascal. №1 даны 2 строки. необходимо вывести слово yes, если строки , и слово no в противном случае. (не использовать функцию compare №2 дан текст, состоящий из 1 слова. определить является ли оно палиндромом. №3 дана строка. вывести те буквы, которые встречаются в строке ровно 2 раза.

Информатика

Ответы

prostopo4ta29

nomer3

program ab;

uses crt

uses sysutils;

var s,s1: string;

i,j: integer;

begin

clrscr;

write('введите строку слово');

writeln;

readln(s);

for i: =1 to length(s) do

for j: =1 to length(s) do

if (s[i]=s[j]) and(i< > j)

then

if pos(s[i], s1)=0

then s1: =s1+s[i]+' ';

write('повторяющиеся символы: ', s1);

readln;

end.

nomer2

program as

uses crt;

var s,sp: string;

i: integer;

begin

clrscr;

write('s=');

readln(s);

sp: ='';

for i: =1 to length(s) do

sp: =s[i]+sp;

if sp=s then writeln ('палиндром')

else writeln ('не палиндром');

readkey

end.

nomer1

function compare(s1,s2: string): boolean;

begin

result: =s1=s2;

end;

var s1,s2: string;

begin

readln(s1);

readln(s2);

if compare(s1,s2) then write('yes')

else write('no')

end.

valya-7777
Program pr;
uses crt; 
Var a,b,c:integer; 

Begin   
Write('Введите 1-ю сторону: '); Readln(a);   
Write('Введите 2-ю сторону: '); Readln(b);   
Write('Введите 3-ю сторону: '); Readln(c); 
  
{Проверка на существование треугольника} 
if ((a+b)>c) and ((a+c)>b) and ((b+c)>a)   then        
     Begin                     
          if ((a=b)or (b=c) or (a=c)) then               
                Writeln('Треугольник равнобедренный');                       
 
         if ((a=b) and (b=c)) then               
            Writeln('Треугольник равносторонний')                 
         else Writeln('Треугольник разносторонний');           
  
        if ((a*a+b*b = c*c) or (a*a+c*c = b*b) or (b*b+c*c = a*a))    then
             Writeln('Треугольник прямоугольный');                      
    end   
   else       Writeln('Треугольник нельзя построить');    

Readln(); 
END.
hrim5736

PascalABC.NET 3.7:

###RS.AdjacentGroup.SelectMany(x → x.Len >= 3 ? x.Len + x[0] : x.Str).Pr

Пояснение:

RS - ReadString: Возвращает значение типа string, введенное с клавиатуры.

AdjacentGroup: Группирует одинаковые подряд идущие элементы, получая последовательность массивов.

SelectMany: Проецирует каждый элемент последовательности в новую последовательность и объединяет результирующие последовательности в одну последовательность.

.Len - .Length: Длина массива.

.Str - .JoinToString: Преобразует последовательность символов в строку, не используя разделитель (при последовательность другого типа данных в качестве разделителя используется пробел).

.Pr - .Print: Выводит последовательность символов на экран, не используя разделитель (при последовательность другого типа данных в качестве разделителя используется пробел).

Пример работы:


Однажды программист вася решил послать своему другу письмо. он подробно рассказал в нем, как у него

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу на pascal. №1 даны 2 строки. необходимо вывести слово yes, если строки , и слово no в противном случае. (не использовать функцию compare №2 дан текст, состоящий из 1 слова. определить является ли оно палиндромом. №3 дана строка. вывести те буквы, которые встречаются в строке ровно 2 раза.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

RozaAsadullina
Yarovitsin
kotikdmytriy11
ekaterinaorl1998
zazaza74
qwerty
magichands68
kostmax1971
utkinslava
mamaevmvv3
anastasiaevent4
okasnab
rastockin8410
gurman171
filimon131262