Lidburg
?>

Напишите программу (в паскаль), которая выведет на печать сумму четных цифр числа и сумму нечетных цифр числа. программа получает на вход натуральное число.

Информатика

Ответы

YekaterinaAbinskov

Объяснение:

Var s,n:integer;

Begin

   write('Введите число: ');readln(n);

   s:=0;

   While n<>0 do

    Begin

     if n mod 10 mod 2 = 0 then s:=s+n mod 10;

     n:=n div 10;

    End;

   if s<>0 then writeln('Сумма четных цифр: ',s)

    else writeln('Нету четных цифр в числе');

   readln;

End.

Может быть неправильной.

Igorevich_Aleksandrovna1599
PascalABC.NET 3.3.5, сборка 1659 от 09.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var (so,se):=(0,0);
  ReadSeqIntegerWhile(t->t>0).ForEach(t->if t.IsOdd then so+=t else se+=t);
  Write('Сумма четных ',se,' ');
  if se>so then Write('>')
  else
    if se=so then Write('=')
    else Write('<');
  Writeln(' суммы нечетных ',so)
end.

Пример
3245 6774 23241 5645 967 32234 123 65 2134 0
Сумма четных 41142 > суммы нечетных 33286

Программа считывает данные, пока они являются натуральными числами.
araqsyabadalyan1988
PascalABC.NET 3.3.5, сборка 1659 от 09.04.2018
Внимание! Если программа не работает, обновите версию!

function NewMatrix(n:integer):array[,] of integer;
begin
  Result:=MatrRandom(n,n,-50,50);
  Result.Println(4); Writeln(4*n*'-')
end;

function KS(a:array[,] of integer):(integer,integer);
begin
  var (k,s,n):=(0,0,a.RowCount-1);
  for var i:=0 to n-1 do
    for var j:=i+1 to n do
      if a[i,j]<0 then (k,s):=(k+1,s+a[i,j]);
  Result:=(k,s)
end;

begin
  var d:=NewMatrix(8);
  var (l,c):=KS(d);
  var t:=NewMatrix(10);
  var (n,a):=KS(t);
  var q:=NewMatrix(7);
  var (m,b):=KS(q);
  Writeln($'l={l}, c={c}, n={n}, a={a}, m={m}, b={b}');
  var (lp,rp):=(c/n+b/l,a/m);
  Writeln($'c/n+b/l={lp}{lp=rp?'' = '':'' <> ''}{rp}');
end.

Пример
 -25  12  43  -8 -15  15 -30  23
   7  49  50   4  38 -37  46  44
  17  21 -37  20  13 -27 -19 -20
   0 -50 -12 -37  23 -33  16 -37
 -43  -6 -35  30  27  11  48  12
   3  15  -8 -25 -38 -47  23  34
 -49  23 -27 -27 -28 -13 -17 -49
 -20  13  42 -16 -24 -43 -50 -10
--------------------------------
 -17  36  -4  -6  48 -34 -33 -44  23   2
 -34  48  32 -45 -32  -3 -22   4 -39 -50
  44  -8  42  20 -39 -36  -1 -36  20  14
 -15  -5  15 -48  43 -24   7 -21  37  36
   5 -33   1  20 -30 -15 -31 -26  -5  -6
 -44  22  46 -50  -4  41  45  26 -17  33
  17 -47 -14 -42 -33  22 -17  30 -37  42
  40  49  18 -24  -5  27  42 -29   0  26
  46 -26  20 -25   7  13  -1  15   6 -48
 -18  31  46 -47 -32   2  31  -8   3  -1
----------------------------------------
 -48 -11 -39   3   5 -43 -46
  20   5  19  50  23 -24   7
  38  -7 -16 -39   2   4 -28
  19 -27 -39   9 -42 -47  15
 -43  43  47  -1  19 -50  24
   6 -38 -34  21   0   9  30
 -41  38 -48   9   5 -12 -35
----------------------------
l=10, c=-275, n=25, a=-654, m=10, b=-369
c/n+b/l=-47.9 <> -65.4

Решить уравнение c/n+b/l=a/m, где l,c – количество и сумма отрицательных элементов матрицы d(8,8) ,

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу (в паскаль), которая выведет на печать сумму четных цифр числа и сумму нечетных цифр числа. программа получает на вход натуральное число.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

kristal1
parolmm
gassvetlana
Alekseeva_Khlistov
semenoffufc8
evada2
Эдуардович873
msangelika1010
MIKhAILOVNAAnton
xachen
Espivak
nevasoundmsk36
Vitalevich1187
Bobkov
Oksana-Kirakosyan1301
▲