silicon-films3375
?>

Напишите программу, которая заполняет массив из n = 8 элементов случайными числами в диапазоне [0, 10], выводит его на экран, а затем выводит на экран квадраты всех элементов массива. с++ использовать библиотеки #include #include

Информатика

Ответы

bristolhouse20151001

Код можно сократить вплоть до одного for, объединив все в одно. На будущее: #include - это не библиотека, это директива

Объяснение:

#include <iostream>

#include <random>

#include <time.h>

using namespace std;

int main() {

int mas[8];

srand(time(NULL));

for (int i = 0; i <= 7; i++) mas[i] = rand() % 11;

for (int i = 0; i <= 7; i++) mas[i] *= mas[i];

for (int i = 0; i <= 7; i++) cout << mas[i] << " ";

}

ldstroy

const N = 8;

var i,min,max: integer;

var a: array [1..N] of integer;

begin

write('Введите массив: ');

min:=0;

max:=0;

for i:=1 to N do  

 begin

 readln(a[i]);

 if (a[i] mod 2 = 0) and (a[i] mod 10 = 2) then

   begin

   if (max=0) then max:=a[i]

   else if (a[i]>max) then  max:=a[i];

   end;

 if (a[i] mod 2 <> 0) and (a[i] mod 10 = 5) then

   begin

   if (min=0) then min:=a[i]

   else if (a[i]<min) then  min:=a[i];

   end;  

 end;

for i:=N downto 1 do  

 begin

 if (a[i]>(max-min)) then a[i]:=a[i]-(max-min);

 write(a[i],' ');

 end;

end.

natalili32

print('Словарь с наименованиями рыб, выберите номер')

print('[1] Речные')

print('[2]Озерные')

print('[3] Морские')

c1=int(input('Ваш выбор: '))

while c1 != '1' or '2' or '3':

    print('Такого номера нет!')

    c1=int(input('Ваш выбор: '))

if c1 == '1':

    print('Судак')

    print('Берш')

    print('Окунь')

    print('Ерш')

elif c1 == '2':

    print('Чоп')

    print('Щука')

    print('Плотва')

    print('Лещ')

else c1 == '3':

    print('Треска')

    print('Налим')

    print('Пикша')

    print('Тихоокеанский минтай')

Объяснение:

Первые команды выводят текст.

Команда "int(input('Ваш выбор: '))" присваивают переменной "c1" выбор пользователя.

"while c1 != '1' or '2' or '3':" означает, что если пользователь выбрал номер, которого нет в списке, то программа запустит цикл, в котором программа выведет текст, что такого параметра нет и программа снова выдаст окно выбора.

Команды ниже создают условие, допустим если переменная c1 будет равна "Речным рыбам", то она выведет на экран речным рыб, так же и со всеми рыбами

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, которая заполняет массив из n = 8 элементов случайными числами в диапазоне [0, 10], выводит его на экран, а затем выводит на экран квадраты всех элементов массива. с++ использовать библиотеки #include #include
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Gera8061
Олег1105
vladimirdoguzov
dariamay1996
mishagoride885
Андреевич-Екатерина1974
annayarikova
Даниил247
Ludmila777020
baulinanatalia7201
azelenkov
Abdullaev
alina Korneev
asvavdeeva
alina-bas