anna-leonova
?>

Составьте программу пайтон с использованием одной функции с переменным количеством аргументов для вычисления сумм чисел 1, 3, 5, 7, 9 и 6, 8, 10.

Информатика

Ответы

ambiente-deco516
Что касается конкретной программы
1. Описываем нужные нам переменные - это будут стороны прямоугольника a и b. Поскольку нигде ничего о размерах сторон не сказано, придется предположить, что они не обязательно будут целыми , мы опишем эти переменные, как вещественные (real), что позволит работать и с нецелыми значениями.
2. Из геометрии нам известны формулы периметра прямоугольника P=2 x (a+b) и площади прямоугольника S=a x b. Можно описать переменные P, S (тоже real), но смысла в этом нет, поскольку значения P и S нужны только для вывода результатов, так что проще написать нужные выражения непосредственно в операторе вывода.
3. Итак, с описанием переменных закончили, можно начинать основную программу ключевым словом begin. И сразу же пишем к нему завершающий end с точкой на конце - таковы правила языка Паскаль. Вся программа размещается между двумя этими ключевыми словами.
4. Сначала организуем ввод. Это два оператора. Первый оператор выводит так называемое "приглашение" - сообщает о том, что нужно ввести. Второй оператор - это сам ввод.
5. А теперь, как было сказано выше, организуем вывод результатов. Все это сделает один оператор вывода. Программа готова!

var
  a, b: real;

begin
  Write('Введите стороны прямоугольника: '); Readln(a, b);
  Writeln('Периметр равен ', 2 * (a + b), ', площадь равна ', a * b)
end.

Тестовое решение:
Введите стороны прямоугольника: 4 3.16
Периметр равен 14.32, площадь равна 12.64
dksvetlydir

Объяснение:

Колонна, состоящая из тринадцати роботов, движется со скоростью 4 см/с. Когда первый робот колонны поравнялся с роботом-инспектором, то робот – инспектор поехал вдоль колонны со скоростью 60 дм/мин, а достигнув её конца, развернулся и вернулся к первому роботу в колонне. Скорость колонны и робота-инспектора постоянны. Длина колонны роботов равна 2 м 10 см. Определите, какой путь проедет робот-инспектор, пока он снова нагонит первого робота в колонне. Временем на разворот можно пренебречь. ответ дайте в дециметрах. В ответ запишите только число.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу пайтон с использованием одной функции с переменным количеством аргументов для вычисления сумм чисел 1, 3, 5, 7, 9 и 6, 8, 10.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

dmitrymakarov003
arammejlumyan
Anatolevich-sergeevna
drontox1031
AOS2015
rs90603607904
Irina_Nikolai
Aleksandrovich-Mayatskikh
hobpack
alexandergulyamov
lzelenyi5
spodobnyi
Verakravez8790
Lenuschakova1982316
margusha1974
▲