Olifirenko119
?>

написать программу на С++ Дано вещественное число A и целое число N (> 0Используя один цикл, вывести все целые степени числа A от 1 до N.

Информатика

Ответы

tat122

что-то типа этого:

const n = 8, m = 8;
var
    A: array[1..n,1..m] of integer;
    i, j, sum, product: integer;
    isnotnull: boolean;
begin
    randomize;
    writeln('Случайная матрица:');    for i:=1 to n do begin
        for j:=1 to m do begin
            A[i,j] := random(51) - 25;
            write(A[i,j]:5);
        end;
        writeln;
    end;    sum := 0;
    for i:=1 to n do
        if A[i,n-i+1] < 0 then
            sum := sum + A[i,n-i+1];
    writeln('Сумма отрицательных элементов побочной диагонали = ', sum);    product := 1;
    isnotnull := False;
    for i:=1 to n-1 do
        for j:=2 to n do
            if (j > i) and (A[i,j] <> 0) then begin
                isnotnull := True;
                product := product * A[i,j];
            end;
    if isnotnull
        writeln('Произведение ненулевых элементов в области выше главной диагонали = ', product)
    else
        writeln('Ненулевых элементов в области выше главной диагонали нет.', product);    readln;
end.

DudukinSerega2507834
Class ArrayMultiplication{
 public static void main(String args[]){
  String fileName = "Array.txt", aNum = ""; int nArray[] = new int[201], iChar; nArray[0] = 0; long rMulti;
  java.io.FileReader iFile = null; java.io.FileWriter oFile = null;
  try{
   iFile = new java.io.FileReader(fileName);
   while((iChar = iFile.read())!=-1)
    if(iChar!=' ')aNum+=(char)iChar;
    else {nArray[++nArray[0]] = new Integer(aNum);aNum="";}
   if(!aNum.equals(""))nArray[++nArray[0]] = new Integer(aNum);
   oFile = new java.io.FileWriter(fileName);
   for(rMulti = 1; nArray[0]>0; nArray[0]--)rMulti*=nArray[nArray[0]];
   oFile.write(rMulti+"");
  }catch(java.io.FileNotFoundException fnfe){
   System.out.println("Файл не был найден!");
  }catch(java.io.IOException ioe){
   System.out.println("Ошибка ввода/вывода в файл!");
  }finally{
   try{
 iFile.close(); oFile.close();
   }catch(java.io.IOException ioe){
 System.out.println("Ошибка закрытия файла ввода/вывода!");
   }
  }
 }
}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

написать программу на С++ Дано вещественное число A и целое число N (> 0Используя один цикл, вывести все целые степени числа A от 1 до N.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

platonovkosty
mar1030
andreyduborezz2913
Devaunka40
Тамара_Григорьевна897
Сергеевна-Иван1045
bakerkirill
zharovaleks
tsigankova2018
vladimirkirv
Vasilevna_Utenkova651
thedoomsdatdcs36
dilovarnazarov1986
Belokonev286
elenakarpova709
▲