У исполнителя омега две команды, которым присвоены номера: 1.прибавь 1 2.припиши справа b Программа 12221 переводит число 5 в число 6556 , определите значение b
Первая команда — 5 + 1 = 6. Потом у нас идут три двойки. Это значит, что мы три раза подставляем какое-то число b к концу текущего (к концу 6). Т.к. в результате мы видим, что после шести у нас стоит две пятерки, это значит, что к шести доставили две пятерки. Третья команда — 2, но после нее идет единица, что говорит о том, что сначала в конец поставляется число b и потом все число увеличивается на единицу. Смотрим: в конце полученного числа стоит шесть. Если убрать единицу, то будет пять, что говорит о том, что число b равно пяти.
ответ: b = 5
artemy682719
17.11.2020
1) F=Av(¬A&B) По закону дистрибутивности раскроем скобки (Av¬A)&(AvB) Av¬A = 1, значит остаётся AvB
2) F =A&(¬AvB) По тому же закону раскрываем скобки (A&¬A)v(A&B) A&¬A = 0, значит остаётся A&B
3. (AvB)&(¬BvA)&(¬CvB) По закону склеивания (AvB)&(¬BvA) = A , получается, что выражение принимает вид A&(¬CvB) Можно раскрыть скобки, получим A&¬C v A&B
4) F =(1v(AvB))v((AC)&1) Скобка (1v(AvB)) = 1, так как 1 v ЧТОУГОДНО = 1 Получаем выражение 1v((AC)&1) = 1, так как 1 v ЧТОУГОДНО = 1 ответ 1
kia80
17.11.2020
Program pr; uses crt;
Var mas:array[1..1000, 1..1000] of integer; N,M,i,j,k:integer;
Begin Writeln('Введите размер матрицы N*M'); Write('N = '); readln(N); Write('M = '); readln(M);
if (M>1000) or (N>1000) or (M<1) or (N<1) then Writeln('Ошибка, указанные значения выходят за пределы матрицы') else Begin Writeln('Введите элементы матрицы');
k:=0; for i:=1 to N do for j:=1 to M do Begin readln(mas[i,j]); if (mas[i,j] mod 2 = 0) then k:=k+1; end;
Writeln(); Writeln('Исходная матрица');
for i:=1 to N do Begin for j:=1 to M do Begin Write(mas[i,j], ' ') end; Writeln(); end;
Writeln(); Writeln('Количество четных элементов = ',k); end;
Начальное число — 5
Выполняем команды:
Первая команда — 5 + 1 = 6. Потом у нас идут три двойки. Это значит, что мы три раза подставляем какое-то число b к концу текущего (к концу 6). Т.к. в результате мы видим, что после шести у нас стоит две пятерки, это значит, что к шести доставили две пятерки. Третья команда — 2, но после нее идет единица, что говорит о том, что сначала в конец поставляется число b и потом все число увеличивается на единицу. Смотрим: в конце полученного числа стоит шесть. Если убрать единицу, то будет пять, что говорит о том, что число b равно пяти.
ответ: b = 5