ikhilovb76
?>

Написать программу решения следующей задачи: Определить, какая из точек A(x1, y1, z1) или B(x2, y2, z2) расположена ближе к точке C(x3, y3, z3 Код нужно написать на языке нужно

Информатика

Ответы

Равилевич_Олеговна1496

#include <stdio.h>

#include <math.h>

#include <locale.h>

main()

{

   setlocale(0, "");

   int x;

   double answer = 0;

   printf("Введите значение X: ");

   scanf("%d", &x);

   if (x >= 0)

   {

     answer = sqrt(pow(x, 3) + 5);

   }

   else if (x > -3 && x < 0)

   {

     answer = 3*pow(x, 4) + 9;

   }

   printf("ответ: %f", answer);

}

Объяснение:

#include <stdio.h>  // Библиотека ввода - вывода

#include <math.h>  // Математическая библиотека

#include <locale.h>  // Библиотека локализации

main()

{

   setlocale(0, "");  // Локализация

   int x;  // Создание целочисленной переменной x

   double answer = 0;  // Создание вещественной переменной answer для хранения ответа

   printf("Введите значение X: ");  // Вывод сообщения в консоль

   scanf("%d", &x);  // Ввод значения x

   if (x >= 0)  // Если значение переменной x ≥ 0

   {

     answer = sqrt(pow(x, 3) + 5);  // Вычисляем верхнее выражение

   }

   else if (x > -3 && x < 0)  // Иначе, если значение переменной x > -3 И < 0

   {

     answer = 3*pow(x, 4) + 9;  // Вычисляем нижнее выражение

   }

   printf("ответ: %f", answer);  // Вывод ответа

}

Викторович Попков

#include <stdio.h>

#include <math.h>

#include <locale.h>

main()

{

   setlocale(0, "");

   int x;

   double answer = 0;

   printf("Введите значение X: ");

   scanf("%d", &x);

   if (x >= 0)

   {

     answer = sqrt(pow(x, 3) + 5);

   }

   else if (x > -3 && x < 0)

   {

     answer = 3*pow(x, 4) + 9;

   }

   printf("ответ: %f", answer);

}

Объяснение:

#include <stdio.h>  // Библиотека ввода - вывода

#include <math.h>  // Математическая библиотека

#include <locale.h>  // Библиотека локализации

main()

{

   setlocale(0, "");  // Локализация

   int x;  // Создание целочисленной переменной x

   double answer = 0;  // Создание вещественной переменной answer для хранения ответа

   printf("Введите значение X: ");  // Вывод сообщения в консоль

   scanf("%d", &x);  // Ввод значения x

   if (x >= 0)  // Если значение переменной x ≥ 0

   {

     answer = sqrt(pow(x, 3) + 5);  // Вычисляем верхнее выражение

   }

   else if (x > -3 && x < 0)  // Иначе, если значение переменной x > -3 И < 0

   {

     answer = 3*pow(x, 4) + 9;  // Вычисляем нижнее выражение

   }

   printf("ответ: %f", answer);  // Вывод ответа

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу решения следующей задачи: Определить, какая из точек A(x1, y1, z1) или B(x2, y2, z2) расположена ближе к точке C(x3, y3, z3 Код нужно написать на языке нужно
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

skryabinamaria
fedchenkoofficial
Borisovich-Volobueva1803
Nazaruk_Kodochigov
АминаИван
purbuevat56524
yrgenson2011801
MAXIM76748
timpavilion23
galinab1111326
abroskin2002
Юрий197
perfectorg
Попова1271
yurazharov