№1 ответ: 133
№2 ответ: 40
№3 ответ: 60
№4 ответ: 1
№5 ответ: 6
Объяснение:
№1 Цикл "s:=s+12;" повторяется благодаря функции "for k:=1 to 11 do" и тем самым к переменной S мы 11 раз прибавляем 12. 1+11*12=133
№2 То же самое, но мы к переменной 5 раз (18-13) прибавляем 8. 8*5=40
№3 К переменной S сперва прибавляем переменную k 3 раза. Переменная k получает номер цикла, то есть в первый раз мы прибавляем 1, потом 2, потом уже 3. В конце программы просто умножаем на 10. S=(1+2+3)*10.
№4 Здесь для совершения цикла необходимо выполнить условие, а именно нужно, чтобы переменная i была больше 1, но из-за того что i у нас изначально равна 1, цикл "y := y + 1/i; i := i - 1;" у нас не выполняется, а значит y=1
№5 В цикле repeat все действия выполняются сразу, но выход из цикла осуществится только при том условии, если i будет больше 5. К концу цикла у нас i будет равен 6, а значит цикл закончится и y будет равен 6 (y:=y+i).
Поделитесь своими знаниями, ответьте на вопрос:
(Паскаль) Составьте программу, которая вводит с клавиатуры два целых числа, а затем выводит их частное и разность, для нахождения разности и частного используя дополнительные переменные. В программе помимо переменных а и b должны использоваться переменные для хранения разности и частного.Пример работы программы:Введите два целых числа a и b12 3Разность: 9Частное: 4
var a,b,c: integer;
var d: real;
begin
writeln('Введите два целых числа a и b');
readln(a,b);
c := a - b;
d := a / b;
writeln('Разность: ',c);
writeln('Частное: ',d);
end.