Галина-Юлия1292
?>

Питон! Напишите программу, которая вводит с клавиатуры значения а и б (а = < b) и выводит квадраты всех целых чисел от а до б в порядке возрастания Напишите программу, которая вводит с клавиатуры значения а и б (а = < b) и выводит все целые числа от а до б в порядке возрастания

Информатика

Ответы

Igorevich1512

1)

a = int(input("Введите a:"))

b = int(input("Введите b:"))

for i in range(a,b+1):

   print(i*i)

2)

a = int(input("Введите a:"))

b = int(input("Введите b:"))

for i in range(a,b+1):

   print(i)

Объяснение:

aidapiltoyan43

(см. объяснение)

Объяснение:

Решение на PascalABC.NET:

##

var a: BigInteger := BigInteger.Subtract(BigInteger.Subtract(BigInteger.Multiply(BigInteger.Parse('3'), BigInteger.Pow(BigInteger.Parse('2'), 32)), BigInteger.Pow(BigInteger.Parse('2'), 10)), BigInteger.Parse('3'));

var b: String;

while(a>0) do

begin

 b:= BigInteger.Remainder(a, 4).ToString+b;

 a:= BigInteger.Divide(a, 4);

end;

print(b.Count(x->x='3'));

Решение на Python3:

a = 3 * 2 ** 32 - 2 ** 10 - 3

b = ''

while a > 0:

   b = str(a % 4) + b

   a //= 4

print(b.count('3'))

Решение на Java:

import java.math.BigInteger;

public class Study

{

public static void main(String[] args)

{

System.out.println(BigInteger.valueOf(3L).multiply(BigInteger.valueOf(2L).pow(32)).subtract(BigInteger.valueOf(2L).pow(10)).subtract(BigInteger.valueOf(3L)).toString(4).chars().filter(x->x=='3').count());

}

}

Результатом работы программ во всех случаях будет одно число 14.

Задание выполнено!

l250sp70

5,25 Мб

Объяснение:

Поскольку разрешение состоит из двух сомножителей - ширины и высоты, то при уменьшении разрешения в 4 раза количество пикселей уменьшится в 4*4=16 раз.

Формула объема файла изображения

V = N*i, где N — общее количество пикселей, а i — глубина цвета (количество бит, выделенное на 1 пиксель)

Составим систему уравнений.

Для первого файла имеем

42=N*i

Для второго файла:

V = N/16 * 2i

Выражаем N в первом уравнении

N=42/i

Подставляем во второе уравнение:

V=42/i :16 *2i

V=42/16i *2i

V=42/8=5,25 Мб

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Питон! Напишите программу, которая вводит с клавиатуры значения а и б (а = < b) и выводит квадраты всех целых чисел от а до б в порядке возрастания Напишите программу, которая вводит с клавиатуры значения а и б (а = < b) и выводит все целые числа от а до б в порядке возрастания
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

moskwa999
Andei
Barabanov Gerasimenko
info2990
vadim1140
verav75
pravovoimeridian
vadim1140
dawlatowajana
myglassi26
profitgroup51
yamalsva45
Мечиславович_Кварацхелия1988
atupicyn754
sarbaevmax
▲