1.Файл — именованная область данных на носителе информации.
Работа с файлами реализуется средствами операционных систем. Многие операционные системы приравнивают к файлам и обрабатывают сходным образом и другие ресурсы.
2.В ОС Windows в имени файла запрещено использование следующих символов: \, /, :, *, ?, ", <, >, |. В Linux эти символы, кроме /, допустимы, хотя использовать их следует с осторожностью, так как некоторые из них могут иметь специальный смысл, а также из соображений совместимости с другими ОС.
3.Txt - блокнот, notepad, TeX
doc - word, openoffice
bmp - photoshop, picaso
rtf - word, openoffice
arj - winrar
4.Флешка
Лазерный диск
Жесткий диск
Любое устройство, подключаемое через USB, с наличием флеш-памяти
5.Каталог — каталог, директория, справочник, папка — объект в файловой системе, упрощающий организацию файлов. Ранее часто использовалось слово директория, которое представляет собой транслитерацию с английского (англ. directory). Типичная файловая система содержит большое количество файлов, и каталоги упорядочить её путём их группировки. Каталог может быть реализован как специальный файл, где регистрируется информация о других файлах и каталогах на носителе информации
6.Файлы могут быть организованы в виде линейной или иерархической файловой структуры
7.Графическое изображение иерархической файловой структуры называется деревом.
8.Путь от диска С:// до самого файла. Например, файл ДОКЛАД.png расположен в папках ШКОЛА, ИСТОРИЯ и на диске С://, тогда его полное имя будет выглядеть так:
С://ШКОЛА/ИСТОРИЯ/ДОКЛАД.png
9.Создание, Открытие, Просмотр, Редактирование, Сохранение, Удаление
Вырезать, Копировать, Вставить, Переместить, Переименовать
10.1) линуксы - пох,
шиндошс - только читабельные символы кроме :,* и ещё вагон включая целые названия типа con, prn
2) линуксы - расширения чтобы пользователю было понятно что за файл, то есть самой системе расширение не важно. здесь не совсем уместно понятие неполного имени файла
винда - по расширению определяется тип файла, то есть чтобы запустить приложение можно напейсать имя файла приложения без расширения
11.Если он только спускался и поднимался, а начальный уровень D:\ - это понятно, тогда это:
2) D:\SCHOOL\CLASS\LESSONS. - то есть, это его начальное место нахождения, откуда он опустился в D:\, ну и дальше поднимался в другой каталог.
12.-
13.A:\TOM3\Doc3
15.заменяет один любой символ, * - любое количество любых символов (в том числе и отсутствие символов).
1) bar.txt - нет символа перед b, не подходит
2) obar.txt - подходит
3) obar.xt - нет символа перед x, не подходит
4) barr.txt - нет символа перед b, не подходит
ответ. 2) obar.txt
16.Биология: клетка- ткань-орган-организм, география: улица-город-область-страна, история: год- век-эпоха.
Объяснение:
Поделитесь своими знаниями, ответьте на вопрос:
Написать программу на Паскале, которая выведет на экран, учебное заведение, где вы обучаетесь(ГАПОУ СО КАРПИНСКИЙ МАШИНОСТРОИТЕЛЬНЫЙ ТЕХНИКУМ)
program Hello;
begin
Writeln('ГАПОУ СО КАРПИНСКИЙ МАШИНОСТРОИТЕЛЬНЫЙ ТЕХНИКУМ');
end.