antoha512
?>

решить на языке Паскаль:В кафе мороженое продают по три шарика и по пять шариков. Можно ли купить ровно k шариков мороженого?Напишите программу, в которой вводится с клавиатуры число k и выводится на экран ответ на поставленныйво

Информатика

Ответы

delfinmos

Объяснение:

Никогда такое не решал, но попробую

На выходе F=1

Идем с конца

До него & (конъюнктор) - это логическое AND

По таблице истинности находим, что На выходе 1, только если на входе 1 и 1, значит А=1

Теперь идем от А. Сначала инверсия, получаем 0

Далее 0 AND B и мы должны получить 1. И тут у меня ломается мозг.

0 AND что угодно - получим 0, а если так, то и F=0 станет.

Вот и логическая бомба.

Решения не вижу у этой задачи, если F=1

Еще функцию надо

F=(A)AND((NOT(A))AND(B))

1=1AND1, значит A=1 и

(NOT(A))AND(B)=1

тогда B=1 и NOT(A)=1.

но NOT(A)=1 и А=1 не может быть. Мы пришли к противоречию.

Утерян "лучший ответ". Нашедшему вернуть.

РоманТрофимов2012

 2)

var i:integer;
begin
writeln('Введите цифру означающюю день недели, например 2-вторник');
readln(i);
case i of
1:writeln('Понедельник: Алгебра,Геометрия,Русский,Физ-ра');
2:writeln('Вторник Информатика,История,Изо');
3:writeln('Среда,Английский,Искусство');
else writeln('ERROR');

readln;
end;

3)

var a:integer;
begin
writeln('Введите ваш возраст');
readln(a);
if (a<7) then writeln('Дошкольник') else
if (a>7) and (a<18) writeln('Ученик') else
if (a>18) and (a<60) writeln('Рабтник') else
if (a>65) writeln('Пенсионер');
readln;
end.

 

 

 

 

 

 

 

 

 

 


 

 

 

 

 

 

 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

решить на языке Паскаль:В кафе мороженое продают по три шарика и по пять шариков. Можно ли купить ровно k шариков мороженого?Напишите программу, в которой вводится с клавиатуры число k и выводится на экран ответ на поставленныйво
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Olga Arutyunyan
Vik1744184
Шмидт Ирина
aaltuxova16
azarovaelena19812
filial2450
vallium8354
devochkadafka624
okykovtun31
supply1590
Rakitin
enot1975
Galina-3639220565
Rudakova_Yana