nalekseeva62
?>

Написать программу, в которой осуществляется ввод целых чисел(ввод до тех пор, пока не будет введен ноль) и подсчет суммы введенных положительных чисел. Сделать блок схемой( )

Информатика

Ответы

f-d-a-14

Добрый вечер. (ночи :) )

Сделать схемкой не могу но вот написал прогу. Надеюсь Сейчас попробую сделать схему, но не обещаю удачи.

(P.S. Протестил)

var a,sum:integer;

begin

 sum:=0;

 repeat

    readln(a);

    if a>0 then  

    begin

       sum:=sum+a;

    end;

 until a = 0;

 writeln('Сумма ',sum:5);

end.

Объяснение:

Кириллов57
Const   n = 5; var   i: integer;   a: array[1..n * 2 + 1] of integer; begin   writeln('исходный массив: ');   for i : = 1 to 2 * n do   begin       a[i] : = random(99) + 1;       write(a[i] : 5);   end;   for i : = 2 * n + 1 downto n + 1 do       a[i] : = a[i - 1];   a[n + 1] : = 0;   writeln();   writeln('полученный массив: ');   for i : = 1 to 2 * n + 1 do       write(a[i] : 5); end.
alakhverdov138
PROGRAM MatrixMax
var a : array [1..3, 1..4] of integer
b : array [1..3] of integer
Max, i, j : integer
BEGIN
crt;
for i:=1 to 3 do 
begin
for j:=1 to 4 do
begin
read (a[i, j]); // вводим элементы в массив a[1..3, 1..4]
end;
writeln; // делаем пустой перевод строки
end;
for i:=1 to 3 do 
begin
b[i] := a[i, 1];
for j:=1 to 4 do
begin
if a[i, j] > b[i] then b[i] := a[i, j];
// находим максимальный элемент в каждой строке и записываем в b[1..3]
end;
end;
Max := b[1];
for i:=1 to 3 do if b[i] > Max then Max := b[i];
// Находим максимальный элемент из максимальных элементов
writeln (Max); // Выводим его на экран
END.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу, в которой осуществляется ввод целых чисел(ввод до тех пор, пока не будет введен ноль) и подсчет суммы введенных положительных чисел. Сделать блок схемой( )
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

irinanikulshina144
Aliferenko
Чечин-Павлова615
ibzaira
Vyacheslavovna240
ievlevasnezhana7
Ляпунов_Владмирович
andruhovich
Юрий197
kotovayaanastasia2069
volkovaekaterina303
Natalya1895
borisova-valeriya
universal21vek116
Александр Джабраиловна1967