oafanasiev41
?>

Составить программу, которая, если введенное число четное, меняет его на противоположное(На языке Pascal)

Информатика

Ответы

lulu777

program pair;

var a, b:integer;

begin

 writeln('Введите число');

 readln(a);

 if a mod 2 = 0 then

 begin  

   a := -a;

   writeln(a);

 end

 else

   writeln('Число нечетное...');

end.

ambiente-deco516
//PascalABC.NET
//Версия 3.3. сборка 1583 (25.11.2017)

begin
 var fio:=ReadlnString('Введите Фамилию Имя Отчество->');
 var b:=0;
 for var i:=1 to fio.Length-1 do
  if (fio[i]='М') or (fio[i]='м')
   then b+=1;
 if b<>0 then Println('Буква "М" есть в строке. Она повторяется',b,'раз(а).')    else Println('Буквы "М" нету в строке.');
end.

Пример:
 1)  Введите Фамилию Имя Отчество-> Миг Мария Моисеева
      Буква "М" есть в строке. Она повторяется 3 раз(а). 

 2)  Введите Фамилию Имя Отчество-> Петренко Петр Петрович
      Буквы "М" нету в строке. 
len4ik1986
Const n=5; m=6;
var 
a:array[1..n,1..m] of integer;
i,j,k,max:integer;
begin
Randomize;
writeln('Исходный массив:');
for i:=1 to n do
 begin
 for j:=1 to m do
  begin
   a[i,j]:=random(100);
   write(a[i,j]:4);
  end;
  writeln;
 end;
max:=0;
for i:=1 to n do
 begin
 k:=0;
 for j:=1 to m do
  if a[i,j] mod 5=0 then k:=k+1;
 writeln(i,': ',k);
 if k>max then max:=k;
 end;
writeln('max = ',max);
end.

Пример:
Исходный массив:
  23   5  72   8  28  14
  25  78  62  10  61  35
  61  30  19  58  98  29
  94  36  58  51  90  10
  34  82  47  92  41  45
1: 1
2: 3
3: 1
4: 2
5: 1
max = 3

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу, которая, если введенное число четное, меняет его на противоположное(На языке Pascal)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

saytru5850
mistersoshnev354
mirdetzhuk79
Belokonev286
Егорова
s9152992722344
ok-49566
symkifm
Дмитриевич Бирковская69
Черепаха в кумире шестиугольник
ale99791308
zaravshan20134
Кириллов57
Yevgenii1423
kraevaea
Nikolaevich-Svetlana388