imiryakubov
?>

Написать программу, которая вводит четырехзначное число и переставляет его вторую и третью цифры местами. Например: из числа 2359 должно получится 2539.

Информатика

Ответы

Natakarpova75732
1. Я бы снимал видео про мою жизнь. Про все хорошие и не очень моменты, про радости и грусти, это был бы своеобразный личный дневник, и плевать я хотел на то, что таких уже полным полно, я хочу снимать именно про это.
2. Мой канал бы назывался 'МояЖизньТВ'
3. Плюсы:
1. можно заявить о себе и стать известным
2. можно раскрыть в себе некоторые таланты, к примеру, ораторские
Минусы:
1. видео необходимо регулярно выкладывать
2. если ты захочешь закрыть канал, это будет проблематично для подписчиков, ждущих новые видео.
4. Я буду относиться к своему каналу хорошо, у меня не будет рекламы в видео, видео будут выкладываться раз в два-три дня.
5. Они бы стали ко мне лучше относиться, подписались бы ко мне на канал, у меня бы появились новые друзья.

Всё сделано лично мной. Копирование запрещено©
muziumednogorsk
// PascalABC.NET 3.3, сборка 1634 от 14.02.2018
// Внимание! Если программа не работает, обновите версию!

type
  CheckBalls=class
 
  private
   
    ad:array of real; // диаметры шариков
    ap:array of real; // веса шариков
    etD:=24.0; // эталонный диаметр
    derD:=2.0; // эталонное предельное отклонение
    etP:=74.0; // эталонный вес
    derP:=3.0; // эталонное предельное отклонение
   
    procedure CheckBall(m:integer);
    // проверка шарика с указанным номером
    begin
      Write('Шарик № ',m,': диаметр - ');
      if Abs(aD[m-1]-etD)<=derD then Write('норма')
      else Write('брак');
      Write(', вес - ');
      if Abs(aP[m-1]-etP)<=derP then Writeln('норма')
      else Writeln('брак')
    end;
  
 
  public
 
    constructor(ma,mp:array of real);
    begin
      ad:=Copy(ma);
      ap:=Copy(mp);
    end;
   
    procedure CheckAllBalls;
    begin
      for var i:=1 to ad.Length do CheckBall(i)
    end;
 
end;

begin
  var n:=120; // число шариков
  var a:=SeqRandom(n,200,280).Select(t->t/10).ToArray;
  var b:=SeqRandom(n,700,800).Select(t->t/10).ToArray;
  Writeln('Параметры шариков (диаметр,вес):');
  a.Zip(b,(p,q)->(p,q)).Println;
  Writeln('Результаты контроля:');
  var oL:=new CheckBalls(a,b);
  oL.CheckAllBalls
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу, которая вводит четырехзначное число и переставляет его вторую и третью цифры местами. Например: из числа 2359 должно получится 2539.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

axo-geo
milleniumwood633
funny-furiya
YekaterinaAbinskov
pannotolstova488
laktionova-natal
veniaminsem
Aleksandr-Andrei
fouettearoma
Yevgenii1423
ermisyareg436
dimalihachew
vovkiv7864
timpavilion23
Getmantsev417