Викторовна
?>

ПО ИНФОРМАТИКЕ, РАЗБЕРИТЕ 2 ЗАДАЧИ, БОЛЬШАЯ К ВАМ, НЕ СОВМЕЩАТЬ ЗАДАЧИ, А РЕШАТЬ ОТДЕЛЬНО БЕЗ ВСЯКИХ ЗАМОРОЧЕК, PASCAL И ТОЛЬКО.

Информатика

Ответы

Irinalobanowa
Всем тем, кому не понятен язык, 2. циклы 1. найти наименьший делитель натурального числа 2. найти все делители натурального числа 3. найти наибольший делитель натурального числа 4. найти сумму делителей числа 600 и их количество 5. найти все делители чисел 90 и 360 6. найти натуральное число, произведение всех делителей которого =5832 7. найти натуральное число, если оно делится на 3 и 4 и имеет 14 делителей 8. подсчитать количество делителей натурального числа, сформированное гениратором случайных чисел в диапазоне от 1 др 10000 9. составить проагрмму, которая нашла бы в интервале от 1 до 1000 число, с наибольшим количеством делителей 10. найти натуральное число в пределах о 1 до 10000 с максимальной суммой делителей 11. составить программу, которая бы напечатала бы все простые числав диапазоне от n до m, а также подсчитать их количество. n и m ввести с клавиатуры 12. между любыми двумя последовательными простыми числами находится заданное число к ? 13. найти и вывести на экран 5 простых чисел, больших заданного к, вводится с клавиатуры. 14. дано простое число р. найти следущее простое число 15. задано некоторое натуральное число р. найти ближайшее к нему простое число. 16. найти все трехзначные числа , кратные 7, сумма цифр которых также кратно 7. если найденное число нечетное , определить , является ли оно простым 17. составить программу поиска трех простых чисел, предшествующих числу м , вводимый с клавиатуры ( м > = 10). 18. составить программу поиска всех цифр - близнецов, принадлежащих заданному диапазону [m , n] . 19. дано простое число. есть ли у него число - близнец ? 20. определить, является числа находящихся по обе стороны от заданного четного числа с , близнецами . 21. является ли заданное натуральное число совершенным ? 22. составить программу поиска всех пар дружественных чисел , меньших 10000 . 23. определить количество разрядов натурального числа n, заданного пользователем . 24. вычислить сумму цифр натурального числа n. 25. записать заданное число n в обратном порядке. 26. составить программу , которая проверяет , является ли число n, вводимое с клавиатуры , палиндромом . 27. найти и напечатать все натуральные числа , которые при возведении в квадрат палиндром . 28. составить программу , которая проверяет , есть ли среди палиндромов в интервале [ 10..1000000 ] простые числа. 29. составить программу , печатающую все нечетные палиндромы в интервале [ 10..1000000 ] . 30. найти и напечатать все натуральные числа в интервале [ 1..2000 ] , равные сумме кубов своих цифр . 31. найти и напечатать все натуральные числа в интервале [ 1..5000 ], равные кубу суммы своих цифр . 32. найти и напечатать все четырехзначные числа , у которых сумма первых двух цифр равна сумме двух последних . 33. в заданном натуральном числе выбросить цифры 3 и 7, оставив неизменным порядок других цифр . 34. проанализировать все числа из диапазона [ 10..1000 ] и напечатать те из них , в записи которых нет цифр 3 и 7 . 35. найти количество шестизначных чисел, у которых все цифры разные. 36. на интервале от n до k выбрать те числа ,которые содержат ровно 3 одинаковые цифры . пример : 6766 , 5444 , 0060 , 0006 . 37. составить программу вычисления цифрового корня натурального числа , введенного с клавиатуры. вычислить и напечатать цифровые корни совершенных чисел, принадлежащих диапазону от х до у, вводящихся с клавиатуры 38. вычислить и напечатать все числа в диапазоне [ 10..9999 ] , кратные своему цифровому корню . 39. вычислить и напечатать все числа в диапазоне [ 100..99999 ], цифровой корень которых: кратный 3 или 5 является простым числом 40. задано 3 натуральных числа. найти нод наибольшего и наименьшего из них. 41. сколько существует натуральных чисел от 20 до 120 , а не взаимно простых с 30 ? 42. сколько существует натуральных чисел, меньших 100 и взаимно простых с числом 36 ? 43. найти все натуральные числа , меньше заданного натурального м и взаимно простые с ним. 44. составить программу сокращения дробей . 45. сравнить две дроби по величине . 46. ​​составить программу сложения ( вычитания ) двух дробей . 47. составить программу умножения ( деления ) двух дробей .
helenavalenti2846
// PascalABC.NET 3.2, сборка 1439 от 09.05.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var p:=ArrRandom(200,-99,99); p.Println;
  Writeln('Числа, кратные трем');
  p.Where(k->k mod 3=0).Println;
  Writeln('Сумма положительных равна ',p.Where(k->k>0).Sum)
end.

Пример
-46 86 -75 83 87 -17 -23 -46 -95 8 19 -2 -93 -18 -47 65 66 81 77 79 30 -40 -76 99 -19 67 -39 25 21 65 64 49 54 -9 18 -98 -43 84 76 -9 64 53 86 -48 -77 -51 -93 22 -31 76 -93 86 -45 -94 92 93 62 -74 3 -79 -77 52 33 -61 44 69 43 15 63 -48 8 82 -94 -14 -84 76 -27 72 76 -67 60 38 -44 45 59 78 -6 48 -1 24 -61 -68 -18 55 -31 -88 -79 48 7 -46 5 -8 58 -82 -31 -75 80 69 90 -83 21 90 -51 -30 -39 -16 -3 87 -20 66 -25 94 -84 -61 -87 -24 0 -50 -82 -96 55 25 -35 23 27 -31 80 -62 -23 34 97 25 58 -17 -96 -51 83 -88 -5 85 15 -67 -31 41 78 11 -24 19 -95 92 24 30 52 86 -39 96 25 26 43 91 3 -41 11 45 68 50 -64 33 -64 64 -7 -11 55 -68 -12 22 -43 24 44 -83 92 -38 -67 -16 -89 -32 73 71 -77 -93
Числа, кратные трем
-75 87 -93 -18 66 81 30 99 -39 21 54 -9 18 84 -9 -48 -51 -93 -93 -45 93 3 33 69 15 63 -48 -84 -27 72 60 45 78 -6 48 24 -18 48 -75 69 90 21 90 -51 -30 -39 -3 87 66 -84 -87 -24 0 -96 27 -96 -51 15 78 -24 24 30 -39 96 3 45 33 -12 24 -93
Сумма положительных равна 5671

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

ПО ИНФОРМАТИКЕ, РАЗБЕРИТЕ 2 ЗАДАЧИ, БОЛЬШАЯ К ВАМ, НЕ СОВМЕЩАТЬ ЗАДАЧИ, А РЕШАТЬ ОТДЕЛЬНО БЕЗ ВСЯКИХ ЗАМОРОЧЕК, PASCAL И ТОЛЬКО.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Яковчук1911
АндреевичАндрей
Vyacheslavovna
nadnuriewa8110
olgusikok
sadinuraliev263
Corneewan
oaved2018
Ляпунов_Владмирович
denbelousov963
galichka12
preida-2
manager9
natkoff5
egorova90356684858370