targovich
?>

Получив на вход число x, этот алгоритм печатает два числа a и b. Укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 12. Текст: program gg; var x, a, b:integer; begin readLn(x); a:=0; b:=0; while (x>0) do begin a:=a+1; b:=b+(x mod 10); x:=x div 10; end; writeLn(a); writeLn(b); end.

Информатика

Ответы

Olesyamilenina8
2 лепешки просто - на одну сторону положила, 1 мин пожарила, перевернула,
еще 1 мин пожарила, сняла. 2 мин.
3 лепешки сложнее, но можно уложиться в 3 мин.
Положила 2 лепешки на одну сторону, пожарила 1 мин. 
Одну лепешку сняла, вместо нее положила 3-ью, а 2-ую перевернула.
Пожарила 1 мин.
2-ую лепешку сняла готовую, положила 1-ую, а 3-ью перевернула.
Пожарила 1 мин.
Всего 3 мин.
4 и 5 лепешек точно также можно пожарить за 4 и 5 мин.
Одну пожарила с одной стороны и заменила на 3-ью, 2-ую перевернула.
Потом также 4 и 5.
spadikov

i'm going to read a lot of books this year. я собираюсь прочесть много книг в этом году.

we hope you will solve all your problems soon. мы надеемся, что вскоре ты решишь все свои проблемы.

when everyone took their places my grandmother said "well, now listen to stories". когда все заняли свои места, моя бабушка сказала: "ну, теперь послушайте ".

i will try to answer all your questions. я постараюсь ответить на все твои вопросы.

we're going to discuss this buisness plan with our partners. мы собираемся обсудить этот бизнес-план с нашими партнёрами.

 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Получив на вход число x, этот алгоритм печатает два числа a и b. Укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 12. Текст: program gg; var x, a, b:integer; begin readLn(x); a:=0; b:=0; while (x>0) do begin a:=a+1; b:=b+(x mod 10); x:=x div 10; end; writeLn(a); writeLn(b); end.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

zakup-r51
Anatolevich-sergeevna
ranocchio6
yurassolo747
insan10
vallzh8328
oniks-plus
Korikm
chulki-kupit
ntinyakova
konss2
sergeykirushev
Николаевич
Троцкая-Ивановна
VASILEVNA