macmakka
?>

ОБЯЗАТЕЛЬНО КУМИР, Составьте программу рисования фигуры, изображенной на рисунке, таким образом, чтобы во время рисования перо не отрывалось от бумаги, и ни одна линия не проводилась дважды

Информатика

Ответы

maltes

Вот ответ долго искала!

https://ru-static.z-dn.net/files/db6/9e8b5c83512a268d2e69bd3282a2731c.jpg

https://ru-static.z-dn.net/files/d47/6724b4435ec60721f22f37effa269f67.jpg

здесь в ссылочку посмотри!

Я думаю я правильно сделала

maxim-xx38

#include <iostream>

#include <vector>

#include <fstream>

#include <algorithm>

using namespace std;

class pacient {

private:

 string lastName_m, mOrFM_m, adress_m, diagnosis_m;

public:

 pacient(string lastName = "", string mOrFM = "", string adress = " ", string diagnosis = " ") {

  lastName_m = lastName;

  mOrFM_m = mOrFM;

  adress_m = adress;

  diagnosis_m = diagnosis;

 }

 string getLastName() {

  return lastName_m;

 }

 string getAll() {

  return lastName_m + ", " + mOrFM_m + ", " + adress_m + ", " + diagnosis_m + ".";

 }

};  

int main() {

fstream out("output.txt");

setlocale(LC_ALL, "Russian");

vector<pacient> arr;

for(int i = 0;;++i) {

 string a[4];

 for(int j = 0; j<4; ++j) {

  switch(j) {

   case 0: cout << "Last name: "; break;

   case 1: cout << "Male or FeMale: "; break;

   case 2: cout << "Adress: "; break;

   case 3: cout << "Diagnosis: "; break;

  }

  getline(cin, a[j]);

 }

 pacient temp(a[0], a[1], a[2], a[3]);

 cout << "Для окончания ввода введите 1: ";

 arr.push_back(temp);

 string temp1;

 getline(cin, temp1);

 if(temp1=="1") {

  break;

 }

}

for(int j = 0; j<1000; ++j) {

for(int i = 0; i<arr.size()-1; ++i) {

 if(arr[i].getLastName()[0]>arr[i+1].getLastName()[0]) {

  swap(arr[i], arr[i+1]);

 }

} }

for(int i = 0; i<arr.size(); ++i) {

 cout << arr[i].getLastName() << endl;

 out << arr[i].getAll();

 out << "\n";

}

out.close();

}


С++ Создайте текстовый файл, содержащий сведения о пациентах глазной клиники: фамилия пациента, пол,
С++ Создайте текстовый файл, содержащий сведения о пациентах глазной клиники: фамилия пациента, пол,
Nataliefremova2015808
Машинная программа представляет собой последовательность команд. В команде программы содержится описание операции, которую должен выполнить компьютер. Как правило, у команды есть свой код (условное обозначение), исходные данные и результат. Например, у команды "сложить два числа" операндами являются слагаемые, а результатом — их сумма. Результат команды вырабатывается по точно определенным для данной команды правилам, заложенным в конструкцию компьютера.
Реальная программа, выполняемая ЭВМ (электронная вычислительная машина), представляет собой последовательность единиц и нулей, которая хранится в памяти машины. Эту цепочку единиц и нулей (бит) называют машинным языком. 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

ОБЯЗАТЕЛЬНО КУМИР, Составьте программу рисования фигуры, изображенной на рисунке, таким образом, чтобы во время рисования перо не отрывалось от бумаги, и ни одна линия не проводилась дважды
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Vladimirovna1370
aivanova
naromanova
dmitriyb1
ilysozkn27
euzdenova
Чубкова1290
Антон-Марина
gulyaizmailova
cvetyzelen283
lobutev
TatyanaVladimirovich
zakupki
ziyaevak
gubernatorov00