Khlustikova_Borisovna
?>

Написать программу на языке Паскаль используя цикл «пока»: Дано число Х = 4. Нужно выводить на экран цифры, кратные 4 пока Х< 100

Информатика

Ответы

AOS2015
#include <iostream>
#include <cstdlib>
#include <ctime>
int main()
{
    using namespace std;
    cout << "Enter size of array: ";
    int N;
    cin >> N;
    int * ARR = new int[N];
    srand(time(0));
    int i;
    for (i = 0; i < N; ++i)
        ARR[i] = rand() % 100 + 1;

    cout << "Here is an original array:\n";
    for (i = 0; i < N; ++i)
        cout << ARR[i] << "  ";
    cout << endl;

    int temp = ARR[N - 1];
    for (i = N - 1; i > 0; --i)
        ARR[i] = ARR[i - 1];
    ARR[0] = temp;

    cout << "\nHere is a new array:\n";
    for (i = 0; i < N; ++i)
        cout << ARR[i] << "  ";
    cout << endl;

    return 0;
}
Larisa Bulgakova
Тексты вводятся в память компьютера с клавиатуры. На клавишах написаны привычные нам буквы, цифры, знаки препинания и другие символы. В оперативную память они попадают в двоичном коде. Это значит, что каждый символ представляется 8-разрядным двоичным кодом.

Кодирование заключается в том, что каждому символу ставится в соответствие уникальный десятичный код от 0 до 255 или соответствующий ему двоичный код от 00000000 до 11111111. Таким образом, человек различает символы по их начертанию, а компьютер - по их коду.

Удобство побайтового кодирования символов очевидно, поскольку байт - наименьшая адресуемая часть памяти и, следовательно, процессор может обратиться к каждому символу отдельно, выполняя обработку текста. С другой стороны, 256 символов – это вполне достаточное количество для представления самой разнообразной символьной информации.

Теперь возникает вопрос, какой именно восьмиразрядный двоичный код поставить в соответствие каждому символу.

Понятно, что это дело условное, можно придумать множество кодировки.

Все символы компьютерного алфавита пронумерованы от 0 до 255. Каждому номеру соответствует восьмиразрядный двоичный код от 00000000 до 11111111. Этот код просто порядковый номер символа в двоичной системе счисления.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу на языке Паскаль используя цикл «пока»: Дано число Х = 4. Нужно выводить на экран цифры, кратные 4 пока Х< 100
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

triumfmodern
pannotolstova488
demakova1969
Varezka86179
Сергеевич1386
makovei78
okasnab
StudioArtNails
Adno1578
Феофанов_Никита1067
mshelen732
kapriz1999
MelnikovaIvanovna
maksimovskiy7657
Evelina Mariya