thebest59
?>

РЕШЕНИЕ Алфавит некоего языка содержит K символов. Определите наименьшую длину кодовых слов при кодировании сообщений на этом языке с равномерного кода алфавита мощностью M. Программа получает натуральные числа K и M. желательно с объяснением что где почему

Информатика

Ответы

Elen-Fler

static void Main(string[] args)

{

int n = Int32.Parse(Console.ReadLine());

int[][] M = new int[n][];

for (int i = 0; i < n; i++)

//вводим массив

M[i] = (Console.ReadLine()).Split(' ').Select(x => Int32.Parse(x)).ToArray();

//ввод вектора

int[] X = (Console.ReadLine()).Split(' ').Select(x => Int32.Parse(x)).ToArray();

for (int i =1; i < M.Length; i+=2)//Если нумерация с 0... либо поставить i = 0 изначально

M[i] = X;

foreach (var x in M)

{

foreach (var Item in x)

{

Console.Write("{0} ", Item);

}

Console.WriteLine();

}

Console.ReadLine();

}

lidiya08083268

--- Python 3.8.3 ---

n = int(input('n: \n'))

counter = 0

for coin1 in range(0, n+ 1):

  for coin2 in range(0, (n // 2) + 1):

      for coin5 in range(0, (n // 5) + 1):

          for coin10 in range(0, (n // 10) + 1):

              if coin1 * 1 + coin2 * 2 + coin5 * 5 + coin10 * 10 == n: counter += 1

print(counter)

для n в пределах 100-200 считает вроде правильно, и достаточно быстро. Что до больших значений n, мне не хватило терпения. Ненормально это, успеть попить чаю в ожидании конца работы программы в 8 строк.

При желании можно использовать как стресс-тест ЦПУ

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

РЕШЕНИЕ Алфавит некоего языка содержит K символов. Определите наименьшую длину кодовых слов при кодировании сообщений на этом языке с равномерного кода алфавита мощностью M. Программа получает натуральные числа K и M. желательно с объяснением что где почему
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Вишняков997
qcrv15312
femida69
mirdetzhuk79
Татьяна-Мишин1307
devochkadafka624
melissa-80
Mariya dmitrievna
glebshramko
st7307
Александрович_Викторовна
nastikak8
pivenraisa
Хохлов
Svetlana ALLA
▲