gameover98
?>

1. Умножить на 2 2. вычесть b Выполняя первую из них , Вычитатель увеличивает число на экране в 2 раза , а выполняя вторую, уменьшает это число на d.Программа для исполнителя Вычитатель - это последовательность номеров команд.Известно, что программа 22122 переводит число 30 в число 0.Определите значение b (b≥2 1. Прибавь 1 2.возведи в квадрат Исполнитель работает только с натуральными числами .Составьте алгоритм получения из числа 1 числа 100, содержащий не более 5 команд

Информатика

Ответы

Natysya7777

1. Умножить на 2 2. вычесть b

Выполняя первую из них ,Вычитатель увеличивает число на экране в 2 раза ,а выполняя вторую,уменьшает это число на d.Программа для исполнителя Вычитатель - это последовательность номеров команд.Известно,что программа 22122 переводит число 30 в число 0.Определите значение b (b≥2).

30-x)-x)*2)-x)-x)=60-4x-x-x=60-2x

60-2x=0

-2x=-60

2x=60

x=30

ответ 30

1. Прибавь 1 2.возведи в квадрат

Исполнитель работает только с натуральными числами .Составьте алгоритм получения из числа 1 числа 100,содержащий не более 5 команд

1+1)+1)^2)+1)^2)=3^2=9+1=10^2=100

11212

ответ 11212

Объяснение:

Tochkamail370
10(10) =2^3+2^1=1010(2)
15(10) = 2^3+2^2+2^1+2^0=8+4+2+1=1111(2)
1010(2) в обратном коде - изменяете 0 на 1, 1 на 0  -> 11110101(2) - обратный код
дополнительный код - это к обратному добавить 1  -> 11110110(2) - дополнительный код
отрицательные числа хранятся в дополнительном коде
15(10) = 1111(2),  обратный код к 1111(2) будет  11110000(2),  дополнительный - 11110001(2)
-15(10) = 11110001(2), дополнительный код к -15(10) будет само число 15
обратный к  -15(2)  ->  00001110(2) ,  добавляем 1  ->  00001110(2) +1 = 00001111(2) = 15(10)
Pastushenkoen
1. "Школьное" решение

// PascalABC.Net 3.0, сборка 1066
var
  s,s1:string;
  i:integer;
  a:char;
begin
  Write('Введите натуральное число любой длины :'); Readln(s);
  Write('Введите цифру, которую надо удалить: '); Readln(a);
  s1:='';
  for i:=1 to Length(s) do
    if s[i]<>a then s1:=s1+s[i];
  Writeln('Результат: ',s1)
end.

Тестовый прогон:
Введите натуральное число любой длины :3141592653589793
Введите цифру, которую надо удалить: 5
Результат: 3141926389793

2. Современное решение (так в школе почему-то не учат)

// PascalABC.Net 3.0, сборка 1066
begin
  var s:=ReadString('Введите натуральное число любой длины :');
  var a:=ReadChar('Введите цифру, которую надо удалить: ');
  Write('Результат: ',s.Replace(a,''));
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1. Умножить на 2 2. вычесть b Выполняя первую из них , Вычитатель увеличивает число на экране в 2 раза , а выполняя вторую, уменьшает это число на d.Программа для исполнителя Вычитатель - это последовательность номеров команд.Известно, что программа 22122 переводит число 30 в число 0.Определите значение b (b≥2 1. Прибавь 1 2.возведи в квадрат Исполнитель работает только с натуральными числами .Составьте алгоритм получения из числа 1 числа 100, содержащий не более 5 команд
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Gennadevna_Baidalina131
Ka-shop2791
delonghisochi
svetlana-sharapova-762621
ALLA1868
Tarakanova_pavel
Дмитрий Бундин
coffeenik20233
ainetdinovsnab
AnastasiyaSkripin1283
bakerkirill
Геннадьевич-Тимофеева158
Оксана170
Letajushaya362
Irinalobanowa
▲