Nugamanova-Tatyana840
?>

1. Отметьте условия, записанные на языке Python правильно. 1) a ≥ 0 2) x <= 3 3) x > 0 or y < 0 4) c ≠ 0 5) a =! b 6) -5 < a < 10 7) x > 0, y < 0 8) a > 10 и b < 5 9) x== 6 10) x = y = z 11) x <> 0 2. Дана программа на языке Python: print ('Введите три числа: ') a, b, c = map (float, input( split ()) x = a if b < x: x = b if c < x: x = c print ('x=', x) Что будет выведено в результате работы программы при следующих входных данных? а) 10 5 1 б) 10 5 7 в) 2 10 5 Постройте блок-схему, соответствующую программе. 3. Напишите программу, которая производит обмен значений переменных x и y, если x больше у Пример входных данных x>>5 y>>6 Пример выходных данных x= 5 y= 6

Информатика

Ответы

sergeykvik13
Локальные сети-это сети,доступные определённому кругу лиц,это может быть несколько компьютеров в одном помещении соединённых частной сетью или кабелем,пользователи которых могут обмениваться друг с другом файлами,информацией.Локальные сети часто используют в офисах где все ПК соединены друг с другом,для того чтобы меняться документами и т.д.При этом файлы доступны только пользователям лок.сети.
Глобальная сеть или интернет-это сеть в которой обьеденены Пк со всего мира.С глоб.сети люди обмениваются информацией,файлами и т.д.Только в отличие от локальной сети они доступны всем.у каждого компьютера,привязанного к глоб.сети есть свой id.Он у каждого ПК разный,что позволяет выделить его среди других.В отличие от локальной.сети,глоб.сеть используют везде в кафе,магазинах и т.д.Локальная сеть полезна в определённом кругу лиц,для частного пользования,а интернетом пользуются все.
MelnikovaIvanovna
PascalABC.NET 3.3.5, сборка 1662 от 29.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var a:=ReadArrInteger(30);
  Writeln('1. Количество четных ',a.Where(t->t.IsEven).Count);
  var s:=a.Where(t->(t mod 3=0) and (t mod 9<>0) and t.Between(10,99));
  Write('2. Мудреное среднее арифметическое ');
  if s.Count=0 then Writeln(-1) else Writeln(s.Average);
  Write('3. Наибольшая длина цепочки четных элементов ');
  var (l,l1):=(-1,0);
  foreach var t in a do
    if t.IsEven then l1+=1
    else begin
      l:=Max(l,l1);
      l1:=0
      end;
  Writeln(l);
  var k:=ReadInteger('4. Номер удаляемого элемента (1-30):')-1;
  Writeln('Массив после удаления элемента');
  a:=a?[:k]+a?[k+1:]; a.Println;
  Write('5. Второй максимум ');
  a.OrderByDescending(t->t).Skip(1).Take(1).Println
end.

Пример
40 -116 91 -47 14 -10 -88 81 92 -106 121 133 -49 69 50 -60 49 57 30 49 60 106 -94 50 -32 -52 -60 -96 148 -49
1. Количество четных 19
2. Мудреное среднее арифметическое 54
3. Наибольшая длина цепочки четных элементов 9
4. Номер удаляемого элемента (1-30): 7
Массив после удаления элемента
40 -116 91 -47 14 -10 81 92 -106 121 133 -49 69 50 -60 49 57 30 49 60 106 -94 50 -32 -52 -60 -96 148 -49
5. Второй максимум 133

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1. Отметьте условия, записанные на языке Python правильно. 1) a ≥ 0 2) x <= 3 3) x > 0 or y < 0 4) c ≠ 0 5) a =! b 6) -5 < a < 10 7) x > 0, y < 0 8) a > 10 и b < 5 9) x== 6 10) x = y = z 11) x <> 0 2. Дана программа на языке Python: print ('Введите три числа: ') a, b, c = map (float, input( split ()) x = a if b < x: x = b if c < x: x = c print ('x=', x) Что будет выведено в результате работы программы при следующих входных данных? а) 10 5 1 б) 10 5 7 в) 2 10 5 Постройте блок-схему, соответствующую программе. 3. Напишите программу, которая производит обмен значений переменных x и y, если x больше у Пример входных данных x>>5 y>>6 Пример выходных данных x= 5 y= 6
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

airlineskozlova69
l250sp70
annanechaeva567
armentamada1906
andruhovich
Николаевич1033
Inozemtseva Korolev1271
Kuznetsova702
bronco-s
M10M11M12
Artur-62838
irkm8
atupicyn754
asvavdeeva
cernovarmechta