nikolotovas
?>

Написать программу на языке Паскаль, которая получает на вход (вы вводите с клавиатуры) трехзначное число, а затем однозначное, программа проверяет, есть ли однозначное число в трехзначном в виде одной из его цифр, программа должна вывести ответ на экран "да есть" или "такой цифры нет" Выполняя это задание назовите любую из переменных своим именем.

Информатика

Ответы

rykovatv6

PascalABC.NET

begin

 var Глебов := ReadInteger('Введи трехзначное положительное число:');

 var Цифра := ReadInteger('Введи цифру от 0 до 9:');

 while Глебов > 0 do

 begin

   if Цифра = Глебов mod 10 then

   begin

     Print('да, есть');

     exit

   end;

   Глебов := Глебов div 10

 end;

 Print('такой цифры нет')

end.

petrowich076813

var trehznachnoe,odnoznachnoe: integer;

begin

write('Введите трехзначное число, а затем однозначное: ');

readln(trehznachnoe,odnoznachnoe);

if (trehznachnoe mod 10 = odnoznachnoe) then

writeln('да есть')

else if ((trehznachnoe div 10) mod 10 = odnoznachnoe) then

writeln('да есть')

else if ((trehznachnoe div 100) mod 10 = odnoznachnoe) then

writeln('да есть')

else writeln('такой цифры нет');

end.

nata27-73589

Объяснение:

Телеконференция - это система обмена электронными сообщениями на определенную тему между абонентами сети (в режиме отложенного общения -offline). Каждый участник получает все материалы на свой почтовый адрес (E:mail). Каждое электронное письмо абонента публикуется на сервере телеконференции и доходит до всех участников.

В отличие от электронной почты, когда пользователь отправляет свое письмо персонально какому-то абоненту или группе абонентов, в телеконференциях письмо направляется одновременно всем ее участникам. В свою очередь, все сообщения, которые поступают в адрес конференции, будут поступать в почтовый ящик пользователя и загружаться в его компьютер во время сеанса связи. Чтобы стать участником телеконференции, на нее нужно подписаться. Для этих целей существуют определенные адреса. Всякая конференция посвящена определенной теме, поэтому переписка в ней происходит только в рамках темы. По некоторым данным число постоянно действующих в настоящее время конференций в Интернете превысило 50000.

Службу телеконференций называют по-разному: группы новостей, служба Usenet. На узлах Сети работу телеконференций обслуживают серверы новостей. На ПК пользователя должна быть установлена клиент-программа новостей. Упомянутая выше программа MS Outlook Express является одновременно почтовым клиентом и клиентом новостей.

Телеконференции объединяют в себе как коммуникационную, так и информационную функции. С одной стороны, здесь происходит личностное общение, с другой — материалы конференции содержат большой объем полезной информации, которая определенное время хранится на сервере. Эта информация может рассматриваться как некоторый информационный ресурс (электронная газета). Это особенно важно для специалистов, участвующих в конференциях по профессиональной тематике: наука, производство, бизнес, торговля и пр. В материалах конференции можно найти ценные советы, консультации, которые в принятии важных решений.

Информационные службы

Информационные службы предоставляют пользователям возможность доступа к определенным информационным ресурсам, хранящимся в Интернете. Такими ресурсами являются либо файлы в одном из общепринятых форматов, либо различные документы. Использование этих ресурсов обеспечивается с соответствующих служб.

Служба передачи файлов

Часто эту службу называют по имени используемого протокола: FTP (File Transfer Protocol — протокол передачи файлов). Со стороны Сети работу службы обеспечивают так называемые FTP-серверы, а со стороны пользователей — FTP-клиенты. Назначение FTP-сервера — хранение набора файлов самого разнообразного назначения (обычно в архивированном виде). Чаще всего это программные файлы: средства системного и прикладного программного обеспечения. Но в наборах могут храниться файлы и любых других форматов: графические, звуковые, документы MS Word, MS Excel и пр. Вся эта информация образует иерархическую структуру папок (каталогов и подкаталогов).

После соединения FTP-клиента с сервером на экране пользователя открывается файловый интерфейс хранилища папок и файлов на сервере (наподобие Проводника Windows). Далее работа происходит так же, как с файловой системой на ПК: папки и файлы можно сорти­ровать, копировать на свои диски. Клиент FTP входит в состав программы Internet Explorer и поэтому всегда имеется на ПК, работающем под управлением MS Windows.

alexandergulyamov

Объяснение:

В 1945 году работала первая в СССР аналоговая машина. До войны же были начаты исследования и разработки быстродействующих триггеров — основных элементов цифровых ЭВМ.

29 июня 1948 года Председатель Совета Министров СССР И. В. Сталин подписал постановление, в соответствии с которым создавался Институт точной механики и вычислительной техники.

В 1948 году под началом доктора физико-математических наук С. А. Лебедева в Киеве начинаются работы по созданию МЭСМ (малой электронной счетной машины). В октябре 1951 года она вступила в эксплуатацию.

В конце 1948 года сотрудники Энергетического института им. Крижижановского И. С. Брук и Б. И. Рамеев получают авторское свидетельствона ЭВМ с общей шиной, а в 1950—1951 гг. создают её. В этой машине впервые в мире вместо электронных ламп используются полупроводниковые (купроксные) диоды. С 1948 г. Брук вёл работы по электронным ЦВМ и управлению с применением средств вычислительной техники.

В начале 1949 года в Москве на базе завода САМ были созданы СКБ-245 и НИИ Счетмаш. Создаются заводы «Счётмаш» в Курске, Пензе, Кишинёве.

Подробнее - на -

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу на языке Паскаль, которая получает на вход (вы вводите с клавиатуры) трехзначное число, а затем однозначное, программа проверяет, есть ли однозначное число в трехзначном в виде одной из его цифр, программа должна вывести ответ на экран "да есть" или "такой цифры нет" Выполняя это задание назовите любую из переменных своим именем.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

versalmoda2971
loa364
ryadovboxing
ivanda
svetsalikowa
Svetlaru70
Deniskotvitsky6422
vanvangog199826
ivanovmk1977
Кочугурова
Павел_Перелыгин
al2nik2ol
miyulcha8077
layna1241383
зырянов_Юрьевна378