alfaduk24908
?>

Написать программу в паскале. Сравнить два числа, если число больше 10 то умножить его на 2, если меньше то прибавить к нему

Информатика

Ответы

Ivan500

program srav;

var

x : integer;

 begin

if x > 10 then

 x := x *2;

if x < 10 then

 x:= x +20;

 end.

Maly01984489
// PascalABC.NET 3.0, сборка 1144 от 16.01.2016
begin
  var n:=ReadInteger('n=');
  var a:=ArrRandom(n,-50,50);
  Writeln('Исходный массив'); a.Println;
  var se:=a.Where(x->x mod 3=0);
  if se.Count=0 then
    Writeln('В массиве нет элементов, кратных трем')
  else begin
    var b:=se.Max;
    var i:=0;
    while a[i]<>b do Inc(i);
    if i=n-1 then Writeln('Максимальный элемент - последний')
    else begin
      Writeln('Результирующий массив');
      a[i+1]:=abs(a.Where(x->x<0).Sum); a.Println
      end
    end
end.

Тестовое решение:
n= 15
Исходный массив
-24 -38 15 -33 -40 -18 21 34 20 49 -19 29 29 38 -41
Результирующий массив
-24 -38 15 -33 -40 -18 21 213 20 49 -19 29 29 38 -41
milkline-nn
1.  и 2. записываем в столбик в виде суммы:

1.       +  n 3 8  9  8
               2 n 7 5  m
           
              m 8 5 n  3
ясно, что основание искомой с/с > 10.  Проверим и удостоверимся, что в 11c|c  действия выполняются верно.
 11 c|c   M=6   n = 4    
ответ: основание системы   11,  m=6,    n=4

2.   m m 65 n
    +2 n 4 4 m         

       5 5 4 2 4      очевидно, что основание искомой с/с > 6. 
Проверим по действиям в 7 с/с,  при сложении в столбик,
  при m=3 и n=1
и удостоверимся, что всё верно.
ответ:    осн. с\с = 7, m=3, n=1

3. пусть основание с\с будет  X? тогда:
(4*X^2+X+5)*4 =2*X^3+2*X^2+6*X+6
    раскрываем скобки, преобразуем и получаем уравнение:
(2*X - 14)*(X^2+1) = 0  --->    X=7
ответ:7

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу в паскале. Сравнить два числа, если число больше 10 то умножить его на 2, если меньше то прибавить к нему
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Zhamynchiev
Шитенков
Владимир
dearmaria
bellenru
svetsalikowa
AndreiFaikov1943
suturinavaleriya51
voloshin238
Екатерина15
Староческуль-Станиславовна
infoproletarskay745
maksimforyou20
testovich1012
Державина