vsemvsego306
?>

В офисных программах есть такая команда, как Регистр, которая меняет регистр букв, заглавную букву заменяет строчной или строчную заглавной Например: A->a, z->Z.

Информатика

Ответы

Коробкова1437

from random import randint

def task_26():

    """

    26. дано число, введенное с клавиатуры.

    определите сумму квадратов нечетных цифр в числе.

    """

    def square():

        number = int(input("number: "))

        s = 0

        for x in str(number):

            if int(x) % 2 ! = 0:

                s += int(x) ** 2

        print("cума квадратов нечетных цифр в числе = {}".format(s))

    square()

def task_27():

    """

    27. найдите сумму чисел, вводимых с клавиатуры.

    количество вводимых чисел заранее неизвестно.

    окончание ввода, например, слово «стоп».

    """

    def number_sum():

        numbers_sum = 0

        while true:

            number = input("number: ")

            if number == 'стоп' or number == 'стоп':

                break

            else:

                numbers_sum += int(number)

        print('suma {}'.format(numbers_sum))

    number_sum()

def task_28():

    """

    28. задана строка из стихотворения:  

    «мой дядя самых честных правил, когда не в шутку занемог,  

    он уважать себя заставил и лучше выдумать не мог»  

    удалите из строки все слова, начинающиеся на букву «м».  

    результат вывести на экран в виде строки.  

    подсказка: вспомните про модификацию списков.

    """

    def word_deleted(line):

        line_split = line.split()

        for i in range(len(line_split) - 1):   # 0,19

            if line_split[i][0] == "м" or line_split[i][0] == "м":

                del line_split[i]

        return line_split

    lines = "мой дядя самых честных правил, когда не в шутку занемог, " \

            "он уважать себя заставил и лучше выдумать не мог"

    print(word_deleted(lines))

def task_32():

    """

    32. создайте матрицу (список из вложенных списков)  

    размера n x n (фиксируются в программе), заполненную случайными  

    целыми числами.

    """

    def new_matrix(n):

        matrix = [[randint(0, 100) for x in range(n)] for i in range(n)]

        for x in matrix:

            print(x)

    new_matrix(10)

def task_45():

    """

    45. напишите функцию, которая возвращает разность между наибольшим и  

    наименьшим значениями из списка целых случайных чисел.  

    """

    def difference():

        number_random = [randint(0, 100) for i in range(50)]

        print('разность между наибольшим и наименьшим значениями = {}'.format(

            (max(number_random) - min(number_random))

        ))

    difference()

def task_46():

    """

    46. напишите программу, которая для целочисленного списка из 1000 случайных

    элементов определяет, сколько отрицательных элементов располагается  

    между его максимальным и минимальным элементами.  

    """

    def num_random_count():

        random_numbers = [randint(-500, 500) for i in range(1000)]

        index_max = random_numbers.index(max(random_numbers))

        index_min = random_numbers.index(min(random_numbers))

        count = 0

        list_range = random_numbers[index_min: index_max + 1]

        for x in list_range:

            if int(x) < 0:

                count += 1

        print("отрицательных элементов между максимальным и "

              "минимальным элементами = {}".format(count))

    num_random_count()

def task_50():

    """

    50. дан список целых чисел. определить количество четных элементов и  

    количество элементов, оканчивающихся на цифру 5.  

    """

    def func(n):

        test_list = [randint(0, 500) for i in range(n)]

        count_num = 0

        count_five = 0

        for x in test_list:

            if x % 2 == 0:

                count_num += 1

            if x % 10 == 5:

                count_five += 1

        print("количество четных элементов {}".format(count_num))

        print("количество элементов, оканчивающихся на цифру 5.   {}".format(

            count_five))

    func(50)

def task_51():

    """

    51. задан список из целых чисел. определить процентное содержание  

    элементов, превышающих среднеарифметическое всех элементов списка

    """

    def func(n):

        test_list = [randint(0, 100) for i in range(n)]

        average = sum(test_list) / len(test_list)

        count = 0

        for x in test_list:

            if x > average:

                count += 1

        print("процентное содержание элементов, превышающих"

              " среднеарифметическое всех элементов списка = {} %".format(

            round((count / average) * 100,

    func(100)

if __name__ == "__main__":

    task_26()

    task_27()

    task_28()

    task_32()

    task_45()

    task_46()

    task_50()

    task_51()

kazan-ugoop36

9.Определите значение переменной a после выполнения фрагмента программы:

a:=10;

b:=3;

if a > b then b:=b+12//а больше б, значит к б прибавим 12 и получим что б 21

else a:=a-7;//а это игнорим

if a > b then a:=a+12//теперь а не больше б(б21 а а 10), так что к а прибавим 12, получаем а 22

else a:=a-7;// а это игнорим

А = 22.

11.Определите что будет напечатано в результате работы следующей программы.

Var k,i: integer;

Begin

k :=4;/к равно 4

For i := 1 to 3 do//следующая строка повториться 3 раза, а и при этом будет меняться от 1 до 3

k := 2*k +i;

// При и равном 1 к станет 9

// При и равном 2 к станет 20

// При и равном 3 к станет 43

Writeln(k);// выведет 43

end.

ответ 43

12.Определите что будет напечатано в результате работы следующей программы.

Var s,i: integer;

Begin

s :=3;

For i := 2 to 5 do// и будет меняться от 2 до 5

s := s+2*i

//К с будет прибавляется 2i т.е. сперва 3;7;13;21;31

Writeln(s) ;//31

end

ответ:31

13.Определите что будет напечатано в результате работы следующей программы.

Var s,n: integer;

Begin

s :=1;

For n := 3 to 8 do//повториться 6 раз

s := s*2// каждый раз s увеличивается вдвое, т.е.это 2 в 6 степени

write(s) ;

end.

ответ:64

14.Чему будет равно значение переменной а после выполнения этого цикла?

i:=4;

a:=12;

while i<6 do begin//по сути он повторится 2 раза, а и будет принимать значение от 4 до 5

a:=a+i;//а увеличиваем на и: сперва это 16, потом 21

i:=i+1

end.

ответ:21

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

В офисных программах есть такая команда, как Регистр, которая меняет регистр букв, заглавную букву заменяет строчной или строчную заглавной Например: A->a, z->Z.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

kotovayaanastasia2069
Ильдар-Кугай
Strelkov567
makscska22879
mir5552
ivnivas2008
Милита1065
shalashcoffee
Stepanovich_Makarov
vakhitov100961
Lianchikavon
orantus3
jurys71242
danceplusru
buff-studio
▲