kashihina
?>

Pascal. 1. Составьте программу, удваивающую значение переменной x, если x>72. Составьте программу, которая проверяет, чтобы два числа, введенные с клавиатуры были различными. Т.е.если числа равны, то вывести сообщение “Ошибка”.3.Вводятся три разных числа. Найти, какое из них является средним (больше одного, но меньше другого4.Определить четверть координатной плоскости, которой принадлежит точка. Координаты точки ввести с клавиатуры.5.С клавиатуры вводятся два числа. Вычислить частное и остаток от деления большего из них на меньшее.6.Даны два действительных числа (вводятся с клавиатуры). Меньшее из них замените полусуммой этих чисел, а большее произведением.​

Информатика

Ответы

dilbaryan76

Объяснение:

- Папа с домашкой, надо вставить пропущенные буквы.

- Давай. "...елеведущая ...анала НТВ." Да всё правильно, не надо ничего вставлять.

ekaterinasamoylova4705

1)var a: integer;

begin

readln(a);

if (a>5) then a:=a*2;

writeln(a);

readln();

end.

сори знаю только первое

Объяснение:

kodim4
Var dv,tr,pt,dv1,tr1,pt1,dv2,tr2,pt2 :real;

procedure nod( var dv,tr,pt,dv1,tr1,pt1,dv2,tr2,pt2 :real; );
var a:array[1..6] of real;
i : integer;
begin
dv1:=100;
tr1:=100;
pt1:=100;
for i:= low(a) to high (a) do begin
readln(a[i]);
repeat
if( (a[i] mod 2) =0) then begin
a[i]:=a[i]/2;
dv:=dv+1;
end
else if( ( a[i] mod 3)=0) then begin
a[i]:=a[i]/3;
tr:=tr+1;
end
else if ( ( a[i] mod 5)=0) then begin
a[i]:=a[i]/5;
pt:=pt+1;
end;

untill(a=1);
if dvif trif ptdv:=0;
tr:=0;
pt:=0;
end;
if dv1>0 then dv2:=dv1*2 else dv2:=1;
if tr1>0 then tr2:=tr1*3 else tr2:=1;
if pt1>0 then pt2:=pt1*5 else pt2:=1;
nod:=dv2*tr2*pt2;
writeln(nod);
end;
begin
nod( dv,tr,pt,dv1,tr1,pt1,dv2,tr2,pt2 );
end.

end;
kiravalter1998697
Задача №1
//PascalABC.NET (версия 3.1, сборка 1196 от 09.03.2016)
Var n, i: integer; 
Begin                   
writeln ('Введите число');
readln(n);                                    
writeln('Делители числа:');  
for i := 1 to n div 2 do     
  if (n mod i) = 0 then begin 
    write(i,'  ');
  end;         
End.       

Задача №2 (алгоритм не очень шустрый, но работает и понятный)
//PascalABC.NET (версия 3.1, сборка 1196 от 09.03.2016)
var
  a, b, x, y, nod: integer;

begin
  writeln('Введите a,b');
  readln(a, b);
  x := a;y := b;
  while x <> y do
    if x > y
      then x := x - y
    else y := y - x;
  nod := x;
  writeln('NOD(', a, ',', b, ')=', nod);
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Pascal. 1. Составьте программу, удваивающую значение переменной x, если x>72. Составьте программу, которая проверяет, чтобы два числа, введенные с клавиатуры были различными. Т.е.если числа равны, то вывести сообщение “Ошибка”.3.Вводятся три разных числа. Найти, какое из них является средним (больше одного, но меньше другого4.Определить четверть координатной плоскости, которой принадлежит точка. Координаты точки ввести с клавиатуры.5.С клавиатуры вводятся два числа. Вычислить частное и остаток от деления большего из них на меньшее.6.Даны два действительных числа (вводятся с клавиатуры). Меньшее из них замените полусуммой этих чисел, а большее произведением.​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Маринова
Теплова
Коробкова1437
inessa12006
Валерьевич Николаевич1364
hotnuts
om805633748
ivanpetrovichru1801
sashakrotova943
printdecor
margo55577869
Coffee3862
T91610933073266
Klochkov malakhov1974
Bella Sergei