?>
С разбором Составить программу и записать ее в тетрадь. Задание. На соревнованиях по прыжкам в длину участвовало 10 спортсменов. Результаты прыжков занесены в массив В [10]. Определите три лучших результата (выведете их на экран program Sortirovka; var n, i, j, x, imax: integer; a:array[1..10] of integer; begin for i:=1 to 10 do read (a[i]); for i:=1 to 10 do write (a[i], ` `); for i:=1 to 9 do begin imax:=i; for j:=i+1 to 10 do if a[j]>a[imax] then imax:=j; x:=a[i]; a[i]:=a[imax]; a[imax]:=x end; for i:=1 to 10 do write (a[i], ` `); end.
Ответы
// Cборка 1590 от 03.12.2017
begin
var a:=ReadReal('Введите зарплату в первый месяц->');
var z:=0.00;
for var i:=1 to 12 do
begin
Writeln('Доход за ',i,' месяц составил ',a:0:2,'р.');
z+=a;
a:=a+a*0.1;
end;
Writeln('Зарплата за год: ',z:0:2,'р.');
end.
Пример:
Введите зарплату в первый месяц-> 100
Доход за 1 месяц составил 100.00 р.
Доход за 2 месяц составил 110.00 р.
Доход за 3 месяц составил 121.00 р.
Доход за 4 месяц составил 133.10 р.
Доход за 5 месяц составил 146.41 р.
Доход за 6 месяц составил 161.05 р.
Доход за 7 месяц составил 177.16 р.
Доход за 8 месяц составил 194.87 р.
Доход за 9 месяц составил 214.36 р.
Доход за 10 месяц составил 235.79 р.
Доход за 11 месяц составил 259.37 р.
Доход за 12 месяц составил 285.31 р.
Зарплата за год: 2138.43 р
P.S Сделал как понял.