shchepinasm
?>

Напишите программу, которая находит наибольшее значение среди чисел, записанных в файле в столбик, и выводит результат в другой файл.

Информатика

Ответы

moskvabelarus

Методические указания предназначены для студентов очного отделения направления 031600 «Реклама и связи с общественностью» по дисциплине «Компьютерные технологии и информатика». Практический цикл посвящен изучению популярнейшего тестового редактора фирмы Microsoft Office Word 2007 (краткое название редактора Word). В настоящее время существует несколько версий этого программного продукта. Однако пользовательский интерфейс и приемы работы в среде Word последних версий практически не отличаются друг от друга, поэтому в методических указаниях нет конкретной привязки к определенной версии редактора. Целью практической работы является самостоятельное обучение основным технологическим операциям и приемам при создании разнообразных документов в среде Word. Практические работы предполагают последовательное изучение краткой теории и выполнение практических заданий. Причем, в основном, теория изучается в процессе выполнения заданий. Такой метод позволяет немедленно закрепить теоретические знания на практике и является достаточно эффективным. Выполнение всех 30 заданий позволит в достаточной степени овладеть основными навыками создания документов в среде Word и подготовит пользователя к самостоятельной работе. Методические указания подготовлены на кафедре «Информационные системы и технологии».

Границы печатаемой зоны (поля) можно задать и с мыши. <...> Кроме вышеуказанного границы абзаца можно установить и с маркеров на горизонтальной линейке <...> Чтобы это сделать необходимо выбрать вкладку «Главная» команду «Границы и заливка». <...> В появившемся окне диалога нужно выбрать закладку «Граница». <...> Чтобы границы ячеек таблицы были видны при печати необходимо указать их обрамление.

Объяснение:

Середа-Сергеенков980
Const
  MAX_SIZE = 10;
 
var
  a: array[1..MAX_SIZE] of integer;
  i, size: integer;
 
procedure delete_odd_elements();
var i, j: integer;
begin
  i := 1;
  repeat
    if odd(a[i]) then
    begin
      dec(size);
      for j := i to size do
        a[j] := a[j + 1]
    end
    else inc(i);
  until i > size;
end;
 
begin
  writeln('Исходный массив: ');
  size := MAX_SIZE;
  for i := 1 to size do
  begin
    a[i] := random(100);
    write(a[i] : 3);
  end;
  delete_odd_elements;
  writeln;
  writeln('Полученный массив: ');
  for i := 1 to size do
    write(a[i] : 3);
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, которая находит наибольшее значение среди чисел, записанных в файле в столбик, и выводит результат в другой файл.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

savenko0109152
Natacha3636672
mototeh69
gsktae7
annabanova9
Ivanova55878
Galiaahmatova4447
Salkinserg
Алина Ракитин1730
korolev-comitet8825
guujuu
postbox
Тарбаева1243
char40
Yeliseeva Verevkin864
▲