1.
program z1;
var a:array [1..10] of integer;
i,k:integer;
begin
write ('Введите элементы массива через пробел и нажмите Enter ');
for i:=1 to 10 do read (a[i]);
write ('Массив: ');
for i:=1 to 10 do write (a[i],' ');
writeln;
write ('Номера элементов больше 5: ');
for i:=1 to 10 do if a[i] > 5 then
begin
write (i,' ');
k:=k+1
end;
writeln;
writeln ('Элементов больше 5: ',k)
end.
2.
program z2;
var s:string;
begin
readln (s);
while pos('о',s)<>0 do delete(s,pos('о',s),1);
writeln(s)
end.
Объяснение:
Смотри картинки
2. Программа удаляет только строчные русские о
1.
program z1;
var a:array [1..10] of integer;
i,k:integer;
begin
write ('Введите элементы массива через пробел и нажмите Enter ');
for i:=1 to 10 do read (a[i]);
write ('Массив: ');
for i:=1 to 10 do write (a[i],' ');
writeln;
write ('Номера элементов больше 5: ');
for i:=1 to 10 do if a[i] > 5 then
begin
write (i,' ');
k:=k+1
end;
writeln;
writeln ('Элементов больше 5: ',k)
end.
2.
program z2;
var s:string;
begin
readln (s);
while pos('о',s)<>0 do delete(s,pos('о',s),1);
writeln(s)
end.
Объяснение:
Смотри картинки
2. Программа удаляет только строчные русские о
Поделитесь своими знаниями, ответьте на вопрос:
Разработать функцию, проверяющую, есть ли отрицательные элементы в указанной строке двухмерного массива. Разработать процедуру, удаляющую указанную строку двухмерного массива. Удаленная строка заполняется нулями и переносится в конец массива. Написать программу удаления всех строк двухмерного массива с отрицательными элементами
function HasNeg(a: array[,] of integer; pRow: integer) :=
a.Row(pRow).Any(p -> p < 0);
procedure DelRow(var a: array[,] of integer; pRow: integer);
begin
var maxRow := a.RowCount - 1;
for var iRow := pRow to maxRow - 1 do
a.SetRow(iRow, a.Row(iRow + 1));
a.SetRow(maxRow, ArrFill(a.ColCount, 0))
end;
begin
var b := MatrRandom(5, 4, -3, 9);
b.Println(3);
for var i := 0 to 4 do
while HasNeg(b, i) do
DelRow(b, i);
b.Println
end.