fixer2006
?>

напишите программу на языке C++ алг суммавещ a sначS:=0A:=1нцпока a<=10S:=S+aA:=a+1кцВывод Sкон​

Информатика

Ответы

annazhurawlewa

Объяснение:

#include <iostream>

using namespace std;

int main()

{

   double a, s;

s=0;

a=0;

while (a <=10){

s = s+a;

a=a+1;

}

cout<<s;

}

jurys71242
Попробуй Program PascalGuru; var s:string;    f,t:text;
function preobr(s:string):string;var i,j,p,n,sered:integer;    gl,zp,slovo:string;    m:array [1..80] of string;beginzp:='!?*,.'; gl:='аоуыэяеёюи';  p:=pos(' ',s); i:=0;        repeat        inc(i);        slovo:=copy(s,1,p-1);        m[i]:=slovo;        delete(s,1,p);        p:=pos(' ',s);        until p=0;        n:=i+1;        m[n]:=s;    for i:=1 to n do     begin    s:=m[i];       if pos(s[length(s)],zp)<>0 then p:=length(s)-1 else p:=length(s);     sered:=(p div 2)+1;    if (not odd(p)) or (p<3) then continue;     if pos(s[1],gl)=0       then continue;     if pos(s[sered],gl)=0   then continue;     if pos(s[p],gl)=0       then continue;      s[1]:=UpCase(s[1]);    s[sered]:=UpCase(s[sered]);    s[p]:=UpCase(s[p]);     m[i]:=s+'('+s[1]+','+s[sered]+','+s[p]+')';     end;         s:='';     for i:=1 to n do s:=s+m[i]+' '; preobr:=s;end;
 beginassign(f,'input.txt'); reset(f);assign(t,'output.txt'); rewrite(t); while not eof(f) do      begin      readln(f,s);      writeln(t, preobr(s) );      end;  writeln('Файл успешно записан...'); close(f);close(t);readln;end.
vikgor45
ОК, всё это циклы.
1) Цикл for (цикл с счётчиком), при этом при каждом шаге цикла счётчик увеличивается на 1. Пример:
for a:=1 to 10 do //Цикл будет выполнен 10 раз
2) Цикл for (цикл с счётчиком), при этом при каждом шаге цикла счётчик уменьшается на 1. Пример:
for a:=10 to 1 do //Цикл будет выполнен 10 раз
3)Цикл с постусолвием. Если условие не выполняется, выполняется цикл. Его особенность заключается в том, что цикл выполнится хотя бы один раз вне зависимости от условия. Пример:
k:=0;
repeat
inc(k);
until k<9 //10 раз
4)Цикл с предусловием. Пока условие выполняется, выполняется и цикл.
Пример:
k:=0;
while k<>10 do
inc(k); //10 раз

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

напишите программу на языке C++ алг суммавещ a sначS:=0A:=1нцпока a<=10S:=S+aA:=a+1кцВывод Sкон​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Vyacheslavovich-Gubanov
karpov68
Yekaterina
kashxb2056
asemchenko
YuREVICh646
btatarintsev
yuda12
artem-whitenoise142
zaalmix
armsam76
martinson
vipteatr
puma802
info126