Дудина895
?>

Составить программу, запрашивающую оценки за контрольные работы по информатике и физике. Если их сумма не менее 8, то на экран должен выводится комментарий «Молодец», в противном случае – «Постарайся» Оценки по физике: 5 5 5 5 5 5 5 5 5 Оценки по информатике: 5 4 4 4 3 3

Информатика

Ответы

Boyaris

#include <iostream>

using namespace std;

int main()

{

   setlocale(LC_ALL, "Russian");

   int GradesInformatics,  GradesPhysikc;

   cout << "Введите количество оценок по информатике" <<endl;

   cin >> GradesInformatics;

   cout << "Введите количество оценок по физике" << endl;

   cin>> GradesPhysikc;

   int* Informatics = new int[GradesInformatics];

   int* Physicks = new int[GradesPhysikc];

   int Tmp = 0;

    cout << "Введите оценки по информатике" <<endl;

   for (int i = 0; i < GradesInformatics; ++i) {

       cin >> Informatics[i];

   }

   cout << "Введите оценки по Физике" <<endl;

   for (int i = 0; i < GradesPhysikc; ++i) {

       cin >> Physicks[i];

   }

   for (int i = 0; i < GradesInformatics + GradesPhysikc; ++i) {

       Tmp = Tmp + Informatics[i] + Physicks[i];

   }

   if (Tmp > 8) {

       cout << "Молодец " << endl;

   }

   else {

       cout << "Постарайся " << endl;

   }

   delete[] Informatics;

   delete[] Physicks;

}

Объяснение:

Код на с++

Так как в задании не указано,сколько всего оценок может быть,то спрашиваем это в рантайме у пользователя. Затем получаем эти оценки при двух циклов for. Потом складываем всё,что получилось в tmp и выводим ответ

andreevaalisa
1 задача

var
X_1, Y_1, X_2, Y_2, AC, BC, AB:real;
begin
writeln('Введите значания X_1 (точки A)');
readln(X_1);
writeln('Введите значания Y_1 (точки A)');
readln(Y_1);
writeln('Введите значания X_2 (точки B)');
readln(X_2);
writeln('Введите значания Y_2 (точки B)');
readln(Y_2);
AC:=X_2-X_1;
BC:=Y_2-Y_1;
AB:=sqrt((AC*AC)+(BC*BC));
writeln('Длинна отрезка AB равна ', AB);
end.

2 задача

var
A, B, C, P, S:real;
begin
writeln('Введите сторону A');
readln(A);
writeln('Введите сторону B');
readln(B);
writeln('Введите сторону C');
readln(C);
P:=(A+B+C)/2;
S:=sqrt(P*(P-A)*(P-B)*(P-C));
if(A+B<=C) or (A+C<=B) or (B+C<=A) then
writeln('Треугольник с такими сторонами не существует')
else
writeln ('Площадь треугольника по теореме Герона равна ', S);
end.
vrn3314
1 задача

var
X_1, Y_1, X_2, Y_2, AC, BC, AB:real;
begin
writeln('Введите значания X_1 (точки A)');
readln(X_1);
writeln('Введите значания Y_1 (точки A)');
readln(Y_1);
writeln('Введите значания X_2 (точки B)');
readln(X_2);
writeln('Введите значания Y_2 (точки B)');
readln(Y_2);
AC:=X_2-X_1;
BC:=Y_2-Y_1;
AB:=sqrt((AC*AC)+(BC*BC));
writeln('Длинна отрезка AB равна ', AB);
end.

2 задача

var
A, B, C, P, S:real;
begin
writeln('Введите сторону A');
readln(A);
writeln('Введите сторону B');
readln(B);
writeln('Введите сторону C');
readln(C);
P:=(A+B+C)/2;
S:=sqrt(P*(P-A)*(P-B)*(P-C));
if(A+B<=C) or (A+C<=B) or (B+C<=A) then
writeln('Треугольник с такими сторонами не существует')
else
writeln ('Площадь треугольника по теореме Герона равна ', S);
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу, запрашивающую оценки за контрольные работы по информатике и физике. Если их сумма не менее 8, то на экран должен выводится комментарий «Молодец», в противном случае – «Постарайся» Оценки по физике: 5 5 5 5 5 5 5 5 5 Оценки по информатике: 5 4 4 4 3 3
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

kostavaani
Igor120
svetkaiv
lazarevaavrora
мурувватовна викторович569
Вот пример: f=(инверсия a^инверсия b) дизъюнкция b
Darialaza
kristina
galinab1111326
Strelkov-Roman1263
Nv-444
Artyukhin545
nat5555
ЛаринаЛощаков
shumilovs7252
igorshevkun