annasv8
?>

очень нужно. Нужно написать программу на языке Python. Напишите программу, которая запрашивает на ввод число. Если оно положительное, то на экран выводится цифра 1. Если число отрицательное, выводится -1. Если введенное число – это 0, то на экран выводится 0. Используйте в коде условный оператор множественного ветвления.

Информатика

Ответы

klodialeit36

a = int(input('введите число:'))

if a > 0:

   print('1')

elif a < 0:

   print('-1')

elif a == 0:

   print('0')

удачи тебе!

maria
Const
  n = 20;

var
  a: array[1..n] of integer;
  b: array[-5..11] of integer;
  i, j, m: integer;

begin
  //Заполнение массива и подсчет кол-ва каждого из интервала
  // от -5 до 11
  writeln('Исходный массив');
  for i := 1 to n do
  begin
    a[i] := random(17) - 5;
    inc(b[a[i]]);
    write(a[i]:4);
  end;
  writeln;
  //Сортировка и вывод массива
  writeln('Отсортированный массив');
  for i := 1 to n - 1 do
  begin
    for j := i + 1 to n do
    begin
      if a[i] > a[j] then begin
        m := a[i];
        a[i] := a[j];
        a[j] := m;
      end;
    end;
  end;
  for i := 1 to n do write(a[i]:4);
  writeln;
 
  //Вывод количества чисел из интервала
 
  for i := -5 to 11 do
  begin
    writeln('Число:', i:4, ' кол-во: ', b[i]:4);
  end;
end.

Тестовое решение:
Исходный массив
   9   4   6   1   8  -5   9   0  -1   0   7   7  -1  -3  -1  -2   7   3  11   4
Отсортированный массив
  -5  -3  -2  -1  -1  -1   0   0   1   3   4   4   6   7   7   7   8   9   9  11
Число:  -5 кол-во:    1
Число:  -4 кол-во:    0
Число:  -3 кол-во:    1
Число:  -2 кол-во:    1
Число:  -1 кол-во:    3
Число:   0 кол-во:    2
Число:   1 кол-во:    1
Число:   2 кол-во:    0
Число:   3 кол-во:    1
Число:   4 кол-во:    2
Число:   5 кол-во:    0
Число:   6 кол-во:    1
Число:   7 кол-во:    3
Число:   8 кол-во:    1
Число:   9 кол-во:    2
Число:  10 кол-во:    0
Число:  11 кол-во:    1
Aleksei
Программа (не проверяет корректность введенных данных, т.е. работает правильно только в случае, если введена корректная дата в формате dd.mm.):
const months:array[1..12] of string=
('января','февраля','марта','апреля','мая','июня',
'июля','августа','сентября','октября','ноября','декабря');
var s,s1,month:string;
d,m,y,code:integer;
begin
write('Введите дату dd.mm. = '); readln(s);
Val(copy(s,1,2),d,code);
s1:=s; 
delete(s1,1,3);
Val(copy(s1,1,2),m,code);
month:=months[m];
delete(s1,1,3);
Val(copy(s1,1,4),y,code);
writeln(d,' ',month,' ',y);
end.

Пример:
Введите дату dd.mm. = 05.04.2016
5 апреля 2016

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

очень нужно. Нужно написать программу на языке Python. Напишите программу, которая запрашивает на ввод число. Если оно положительное, то на экран выводится цифра 1. Если число отрицательное, выводится -1. Если введенное число – это 0, то на экран выводится 0. Используйте в коде условный оператор множественного ветвления.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Юрьевич293
ИгоревичАндрей
Решите поберегите мои нервы.
Анатольевич-Лариса
northwest7745
Donleksa2016
obar1
kabanovae
milo4ka26
pnatalia
nataliagoncharenko
karavan85450
Ofelya1308
Anatolevich-sergeevna
phiskill559
s-food