ИринаАлександровна
?>

Составить программу : Определить периметр прямоугольника со сторонами а, в. Паскаль

Информатика

Ответы

mishamedbrat

ответ:Это самое короткое что я знаю

Объяснение:#include <iostream>

#include <cstring>

using namespace std;

int main() {

   char s[100], *ps = s, ch, mch;

   int mn = 100, n = 0;

   cout << "string? ";

   cin >> s;

   ch = *ps;

   do {

       ++ps;

       ++n;

       if (ch != *ps) {

           if (mn > n) {

               mn = n;

               mch = ch;

           }

           ch = *ps;

           n = 0;

       }

   } while (*ps);

   cout << "result: ";

   for (int c = 0; c < mn; ++c) cout << mch;

   return 0;

}

belegaj98

var

 i, p, n, q, sum: integer;

 a : array[1..1000000] of byte;

begin

 Write('Введите число N: ');

 ReadLn(n);

 Write('Введите основание системы счисления q: ');

 ReadLn(q);

 p := n;

 while p > 0 do

   begin

     i := i + 1;

     a[i] := p mod q;

     sum := sum + a[i];

     p := p div q;

   end;

 Write(n,'(10) = ');

 for p := i downto 1 do

   Write(a[p]);

 WriteLn('(', q, ')');

 WriteLn('Сумма цифр полученного числа равна ', sum);

 WriteLn('Количество цифр полученного числа равна ', i);

end.

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу : Определить периметр прямоугольника со сторонами а, в. Паскаль
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Палкина-Дроздова
milanparipovic864
sryzhova6392
zibuxin6
Некрасов Валентина1097
annaan-dr582
fialkaflowers77
Rafigovich1267
bulenbeiser
lenapopovich556510
inessa12006
alenchik19938823
smnra219
oksanashabanovadc3197
ПодлеснаяМакарова1883