deadnobody
?>

33. В ряду из десяти клеток перед РОБОТом некоторые клетки с цветами. а) напишите программу в которой РОБОТ посадит цветы в грядки ниже каждой клумбы (команду грядка – использовать нельзя); б) напишите программу в которой РОБОТ посадит цветы в грядки ниже и выше каждой клумбы (команду грядка – использовать нельзя); 34. Напишите программу, с которой РОБОТ придет на Базу во всех трех лабиринтах. 35. Напишите программу, с которой Робот сможет пройти по извилистому коридору. Коридор имеет ширину в одну клетку и идет в направлении слева-снизу вправо-вверх. Пример возможного коридора:

Информатика

Ответы

koptevan6

Цикл «пока»:

Frame1hello_html_3907e2dc.gif

Полная форма ветвления

Frame2hello_html_m2c0402b5.gif

hello_html_m628ac47d.gif

Краткая форма ветвления

Frame3

Объяснение:

MN-Natusik80
ПОСЛЕДОВАТЕЛЬНОСТЬ ФИБОНАЧЧИ, математическая ПОСЛЕДОВАТЕЛЬНОСТЬ, каждый член которой является суммой двух предыдущих. Таким образом, если энный член последовательности обозначается хn, то для всей последовательности справедливым будет уравнение: хn+2=хn+хn+1, первыми двумя членами которого будут x1=l и x2=1. Порядок последовательности при этом таков: 1, 1, 2, 3, 5, 8, 13, 21..., следующим числом будет 34, т. к. сумма 13 и 21 равна 34 и т.д. Когда число n становится очень большим, отношение соответствующих членов устремляется к величине (Ц5+l)/2. Это соотношение называется золотым. В природе последовательность Фибоначчи можно проследить на примерах спирального развития сегментов раковины и лепестков подсолнуха, расходящихся лучами из одной точки в центре цветка. см. также ЗОЛОТОЕ СЕЧЕНИЕ. 
baranovaas
// PascalABC.NET 3.1, сборка 1200 от 13.03.2016

function gcd(a,b:integer):integer;
// Нахождение НОД
begin
  while b<>0 do
  begin
    a:=a mod b;
    var i:=b; b:=a; a:=i
  end;
  Result:=a
end;

procedure Shorter(var a,b:integer);
// "сокращатель" дроби
begin
  var k:=gcd(a,b);
  a:=a div k;
  b:=b div k
end;

begin
  var a,b:integer;
  Writeln('Введите числитель и знаменатель дроби: ');
  Read(a,b);
  Write(a,'/',b,'='); Shorter(a,b); Writeln(a,'/',b)
end.

Тестовое решение:
Введите числитель и знаменатель дроби:
25 15
25/15=5/3

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

33. В ряду из десяти клеток перед РОБОТом некоторые клетки с цветами. а) напишите программу в которой РОБОТ посадит цветы в грядки ниже каждой клумбы (команду грядка – использовать нельзя); б) напишите программу в которой РОБОТ посадит цветы в грядки ниже и выше каждой клумбы (команду грядка – использовать нельзя); 34. Напишите программу, с которой РОБОТ придет на Базу во всех трех лабиринтах. 35. Напишите программу, с которой Робот сможет пройти по извилистому коридору. Коридор имеет ширину в одну клетку и идет в направлении слева-снизу вправо-вверх. Пример возможного коридора:
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

vsemvsego306
olgavlad199
Ryadovboxing23
Jannadon77
Mikhailovna1444
annakorolkova79
Александровна-Васильевна
ievlevasnezhana7
Buninilya
denisovatat7
АндреевичЮлия
4 div 10 решите ответ дайте
Wlad967857
ИвановнаВладимир1832
Lapushkina
Shishkinna2002